Introduccio

JkDefragGUI versi o 1.03

JkDefragGUI made by Emiel Wieldraaijer

JkDefragGUI es una GUI “Interfaç Grafica d'Usuari” que li permet triar facilment totes les característiques de JkDefrag, una ferramenta de desfragmentacio lliure i debades feta per Jeroen Kessels que te molt que oferir. Pero este programa pot fer prou mes.

JkDefragGUI pot programar una desfragmentacio, instalant JkDefrag o el salvapantalles pero tambe pot fer algun chicotet manteniment mes en el seu ordenador. pot usar-se per a programar una desfragmentacio dels seus archius de sistema com l'archiu de la memoria virtual "pagefile.sys" i de l'archiu del Registre. JkDefragGUI tambe soporta CCleaner que pot usar-se en lloc de la funcio interna de neteja. Aço tambe pot borrar qualsevol informacio que es deixada en el seu disc dur despres de borrar els archius.

JkDefragGUI s'ha creat per persones que no tenen les habilitats d'un usuari avançat i els ajuda a utilisar les poderoses caracteristiques que JkDefrag te que oferir o per a eixes persones que preferixen usar una Interfaç Grafica de l'Usuari en lloc de la llinea de comando.

JkDefragGUI es compatible en el format U3 de les memories USB i en l'entorn de preinstalacio BartPE.

© Emiel Wieldraaijer 2007/2008

Website : http://www.emro.nl/freeware / Email : emielwieldraaijer@hotmail.com

Revisio 1.03


End User License Agreement (EULA)

JkDefragGUI EULA – Llicencia final d'usuari

JkDefragGUI es un programa debades i se suministra tal com es, sense cap garantia.

Voste pot usar este programa baix el seu propi risc.

L'autor no es responsable de cap mal causat per este programa.

JkDefragGUI pot ser distribuit lliurement, a condicio de que el paquet del programa no siga modificat.

Ninguna persona o empresa pot cobrar una retribucio per la distribucio de JkDefragGUI sense permis escrit de l'autor


Introducci o
  • Caracteristiques principals
  • Requeriments del sistema
  • U3
  • BartPe


Caracter i sti que s principals
  • Desfragmentar l'ordenador
  • Apagar l'ordenador despres de la desfragmentacio
  • Eixecutar una desfragmentacio oculta
  • Instalador de JkDefrag
  • Instalador del salvapantalles de JkDefrag
  • Programar una desfragmentacio des de la GUI en les opcions que voste vullga
  • Instala i programa una desfragmentacio de l'archiu de paginacio i de l'archiu de Registre
  • Netejar l'ordenador
  • Optimisa i compacta el Registre
  • Automaticament revisa en busca d'una versio actualisada de JkDefrag
  • Borrar senyes confidencials de l'espai lliure en el disc dur
  • Vore archius de registre de JkDefrag


Requeriments del sistema
  • Sistemes operatius Windows 2000, Windows XP, Windows 2003 Windows Vista o Windows 2008
  • Un minim de 6 MB d'espai del disc


U3

JkDefragGUI es compatible en la tecnologia U3.

Les opcions son guardades en la memoria U3 i se quedaran alli durant l'us de JkDefragGUI.

JkDefragGUI finalisa la desfragmentacio quan la seua memoria U3 es estreta o llevada del seu sistema.

¡Almagasene les seues senyes i lleve els seus programes!

Imagine portar els seus programes en la mateixa unitat flash que porta els seus archius. Aixo es lo que voste pot fer en un chicotet disc U3. Voste pot conectar el pendrive en qualsevol PC, pot treballar, jugar, enviar mensages als amics, enviar correu electronic, pot editar fotos i desfragmentar o netejar per complet l'ordenador en JkDefragGUI. Un chicotet pendrive U3 fa de qualsevol PC el seu propi ordenador personal. I quan voste el desconecta, no deixa arrere senyes personals.

Veja mes programes en U3 software central


BartPE

¿Que es BartPE i PE Builder?

Bart PE Builder li ajuda a construir a un "BartPE" (Entorn Bart Preinstalat) un CD-ROM o DVD arrancable de Windows des d'un CD d'instalacio original de Windows XP o Windows Server 2003, molt adequat per a tarees de manteniment del PC.

Li donara un entorn complet Win32 en soport de ret, una Interfaç Grafica d'Usuari de (800x600) i un sistema d'archius FAT/NTFS/CDFS. Molt convenient per a gravar un sisteme de proves sense sistema operatiu, per a rescatar archius d'una ret, escanejar virus etc. Aço reemplaçara qualsevol disc d'arranc.

Per a mes informacio al voltant de BartPe visite el lloc web :http://www.nu2.nu o http://www.911cd.net/forums

Totes les funcions extra no estan disponibles en la versio BartPE de JkDefragGUI nomes les opcions del desfragmentador de Jeroen Kessels. La desfragmentacio feta a traves d'un CD o DVD BartPE te una gran ventaja: Cap d'archiu esta en us, aixina es que cada archiu pot ser desfragmentat.


JkDefragGUI

  • Pestanyes de la GUI

  • Menu
  • Bandeja de sistema
  • Tecles d'acces rapit
  • Llinea de comandos


Pesta nye s de la GUI
  • General
  • Avançat
  • Opcions
  • Programador
  • Instalador
  • Sistema
  • Netejador
  • Llavant


General

Pesta nye s de la GUI - General

La pantalla general cobrix els elements basics de JkDefrag

  • Accio - Use el menu desplegable per a seleccionar una accio, la qual satisfaga la seua situacio lo millor possible.
  • Nivell de depuracio - Use el menu desplegable per a seleccionar el nivell de depuracio de JkDefrag per a l'archiu de registre.
  • Disc - Voste pot seleccionar un disc de la seua eleccio o pot usar la caixa de verificacio per a seleccionar tots els discs fixes. JkDefrag soporta el desfragmentat d'atres discs, pero per defecte esta deshabilitat en la GUI. Voste pot habilitar estos dispositius per a revisar canviant una opcio en la seccio “dispositius” de la pestanya de “Opcions”.
  • Velocitat – Es possible baixar la velocitat de JkDefrag per a que consumixca menys recursos del sistema. La velocitat normal te un valor de 100 i es la configurada per defecte.
  • Espai lliure - El tamany de l'espai lliure es fixa en N per cent de (0... 100) del tamany del volum. L'espai lliure son quatre arees del disc per a archius temporals. Hi han 2 espais lliures, entre les 3 zones (directoris, archius normals i space hogs "espai brut"). Per defecte es el 1% (de l'espai lliure).

Quan JkDefragGUI s'inicia per primera vegada la GUI utilisara les opcions predeterminades de JkDefrag.


Avançat

Pesta nye s de la GUI - Avan çat

La pestanya avançat gestiona els parametros mes avançats que voste pot fer en JkDefrag.

  • Incloure - Nomes els archius i/o directoris que coincidixquen en la caraça seran desfragmentats en lloc de la seleccio de discs de la pestanya general. Es possible afegir un disc a l'opcio incloure. Utilise comodins '*' i '?' en la caraça per a que coincidixquen en un grup d'archius o directoris. Alguns eixemples: "*.avi","*\w3svc*\*.log","d:\mysql\data\*"
  • Excloure - Nomes els archius i/o directoris que coincidixquen en la caraça no seran desfragmentats i no seran moguts. Utilise comodins '*' i '?' en la caraça per a que coincidixquen en un grup d'archius o directoris. Alguns eixemples: "*.avi","*\w3svc*\*.log","d:\mysql\data\*"
  • Moure estos archius al final (Spacehogs) - Els archius que coincidixquen en la caraça seran moguts a l'area Spacehogs. El programa te una llista per a tots els archius mes grans de 50 megabytes, archius als que no s'accedit en l'ultim mes, archius comprimits, archius en la paperera de reciclage, archius de service pack, i alguns atres.
  • Archiu de registre - Quan la casilla de verificacio esta desmarcada no se creara un archiu de registre en l'informacio sobre la desfragmentacio. L'archiu de registre es guarda en la carpeta temporal per defecte. Aço pot canviar-se des del boto seleccionar.
  • Guardar l'archiu de registre en la carpeta de la GUI - Esta opcio guardara l'archiu de registre en la mateixa carpeta on JkDefragGUI estiga ubicat. Aço desactivara el boto seleccionar


Opcions

Pesta nye s de la GUI - Opcions

La pestanya d'opcions te quatre seccions i un deslisador utilisat per a fixar la transparencia de la GUI.

  • A l'inici - Totes estes opcions s'eixecutaran a l'inici de la GUI
  • Dispositius - Esta seccio controla els dispositius per a afegir a la seleccio de discs en la pestanya general
  • A l'eixida - Estes opcions s'eixecutaran al finalisar i eixir de la GUI
  • Varios - Esta seccio te algunes opcions mes

Hi han dos botons baix la barra de desplaçament, La X roja desactiva la transparencia. L'icon de disc s'utilisa per a guardar la transparencia a l'archiu JkDefragGUI.ini


A l'inici

Opcions – A l' inici
  • Comprovar actualisacions a l'inici - Quan JkDefragGUI s'inicie fara una conexio a la seccio de programes debades d'EMRO Automatisering i comprovara un archiu en informacio sobre les versions de la GUI i de JkDefrag. Quan trobe una versio actualisada, s'oferira per a descarregar la versio actualisada de la GUI o instalar la versio actualisada de JkDefrag.
  • Restaurar-ho tot per defecte en el següent inici - Quan esta opcio esta seleccionada, en el següent inici de JkDefragGUI seran restaurats per els originals els següents archius: Els archius d'ajuda, idioma, so, i els archius de text adicionals per a que la configuracio torne a estar en els valors per defecte
  • Preguntar un atra vegada si vol descarregar Pagedefrag a l'inici - Quan s'ha iniciat el GUI per primera vegada pagedefrag no esta disponible fins que es descarregue del lloc de Microsoft. Durant l'inici li preguntaran si vol descarregar Pagedefrag. Pot seleccionar Si, No o Cancelar. Si tria Si es descarregaran e instalaran les opcions de pagedefrag en el GUI. Si selecciona No, no li preguntara un atra vegada si vol descarregar pagedefrag, voreu en la seccio de preguntes FAQ . Si selecciona Cancelar, li tornara a preguntar un atra vegada despres de reiniciar el programa.


Dispositius

Opcions - Dispositius
  • Detectar disc extraible - Els disquets, memories USB, IPods, targetes de memoria, discs Jazz, discs ZIP.
  • Mostrar disquet (si esta present) - Quan un disquet es introduit en l'ordenador i esta opcio esta seleccionada, es possible desfragmentar el disquet.
  • Detectar ramdisks - Els RamDisks son unitats virtuals creades en la memoria o imagens almagacenades en un disc.


A l'eixida

Opcions - A l'eixir
  • Borrar archiu de registre a l'eixir - Quan tria aço, l'ultim archiu de registre es borrat al tancar la GUI.
  • Apagar despres de desfragmentar - Aço causara l'apagat de l'ordenador despres de que JkDefrag es tanque, encara que es tanque manualment. Esta opcio no pot guardar-se.
  • Guardar configuracio a l'eixir - Quan la GUI es tanca i esta opcio esta seleccionada tots els ajusts i totes les opcions seran guardades en l'archiu de configuracio excepte l'opcio "Apagar despres de desfragmentar".


Varios

Opcions - Varios
  • Ocultar el programador de tarees - Quan esta opcio esta activada i hi ha una tarea programada no sera visible en el Panel de control en les Tarees programades.
  • Tancar JkDefrag Quan haja finalisat - Aço finalisara automaticament la pantalla de JkDefrag Quan la desfragmentacio haja finalisat (parametro -q).
  • Spacehogs "Espai brut " per defecte - En el Spacehogs estan els archius menys importants que ocupen una bona cantitat d'espai. JkDefrag els mou darrere dels directoris i els archius normals, per a fer ha estos mes rapits. Voste pot trobar la llista interna de spacehogs http://www.kessels.com/JkDefrag en la seccio del FAQ. Voste pot afegir mes a la llista en la pestanya “Avançat” (No olvide guardar els ajusts o marcar "Guardar configuracio a l'eixir" per a guardar-lo automaticament).
  • Escoltar un so al finalisar - Quan finalisa la desfragmentacio s'ecoltara un so, l'archiu de so pot canviar-se (finished.mp3 en la carpeta de sons).
  • Borrar senyes en espai sense utilisar - Aço fara mes dificil recuperar els archius eliminats.
  • Eixecutar l'opcio de neteja abans de desfragmentar - Aço eixecutara totes les opcions seleccionades en la pestanya "Netejador".

JkDefragGUI te soport per a CCleaner, Quan CCleaner.exe i ccleaner.ini son copiats a la carpeta "Programs", la seccio "Varios" te un atra opcio que no esta visible si eixos archius no estan copiats alli. Quan "Utilisar CCleaner " esta seleccionat, les opcions de la pestaña "Netejador" son reemplaçades per les opcions de CCleaner excepte una "Optimisacio del Registre" que es eixecutada quant esta seleccionada.


Programador

Pesta nye s de la GUI - Programador

¿Per que desfragmentar l'ordenador manualment? En JkDefragGUI voste pot programar una desfragmentacio per a eixecutar una sola vegada, diariament, semanalment, mensualment o en l'arranc. Quan una tarea esta programada en JkDefragGUI per a eixecutar-se mes vegades voste pot voreu mijant el text entre els dos botons sobre el fondo de la pestanya, que estara vert quan una tarea estiga programada i sera roig quan no haja cap de tarea programada. Quan el conte d'usuari no te contrasenya, pot deixar buit el camp de contrasenya del programador.

Quant has triat l'interval "entrada en el sistema " esta disponible l'opcio de retart. Este programara JkDefrag per a perseguir l'entrada en el sistema i esperar una cantitat en segons abans de començar. Aço permetra al sistema arrancar sense el retart del deframentador en el proces d'arranc.


Instalador

Pesta nye s de la GUI - Instalador

JkDefragGUI te dos instaladors incorporats

  • Instalador de Windows
  • Instalador del Salvapantalles


Instalador - Windows

JkDefragGUI pot instalar JkDefragGUI en el seu ordenador. Creara els accessos directes necessaris i colocara JkDefragGUI en la llista de programes del seu ordenador. Aço li creara una opcio per a desinstalar JkDefragGUI com a qualsevol atre programa. Quan JkDefragGUI es instalat mijant l'instalador incorporar, voste podra facilment actualisar els accessos directes seleccionant o deseleccionant les casilles de verificacio i pulsant el boto per a que se produïxca el canvi (El boto Instalar efectua els canvis despres d'instalar).


Instalador - Salvapantall e s

Jeroen Kessels ha creat una versio de salvapantalles del seu programa de desfragmentacio que pot ser comodo... desfragmenta l'ordenador automaticament quan no esta utilisant-se. Pero el salvapantalles te que copiar-se manualment a la carpeta System32 de la seua instalacio de Windows i despres voste tindra que configurar el salvapantalles. JkDefragGUI simplifica este proces per a voste, seleccione les seues opcions i pulse el boto d'instalacio. Quan el salvapantalles estiga instalat i configurat en l'ordenador, voste podra canviar facilment la configuracio des de la GUI o pot llevar el salvapantalles del seu ordenador. Un atra ventaja de la GUI es l'actualisacio automatica del salvapantalles. Quan JkDefragGUI te una versio mes nova del salvapantalles podra actualisar-la automaticament quan la GUI s'inicia.

  • Interval d'espera - Marca el temps en minuts per a que el salvapantalles s'active.

  • Barra d'estat - Tria el modo per a mostrar l'informacio quan el salvapantalles de JkDefrag esta activat.

  • No desfragmentar si la volta anterior fa menys de x horas - Este interval en hores desactiva el salvapantalles de JkDefrag despres de que haja finalisat i mostra el salvapantalles alternatiu.

  • Alternatiu - Tria el salvapantalles alternatiu que sera utilisat per l'anterior seleccio.

  • Llinea de comandos - Fixa els comandos que utilisara el salvapantalles de JkDefrag. Voste els pot posar manualment o a traves de la GUI pulsant el boto de la dreta. El boto roig en la X borrara la llinea de comandos.


Sistema

Pesta nye s de la GUI - Sistema

La pestanya Sistema et permet instalar pagedefrag de Sysinternal. PageDefrag utilisa tecniques alvançades per a fer lo que els desfragmentadors comercials no poden: L' habilitat per a desfragmentar l'archiu de paginacio o memoria virtual i registres. Ademes d'aixo, els archius de registre d'events de les desfragmentacions i els archius d'hivernacio de Windows 2000/XP (on la memoria del sistema se guarda quan voste hiverna una computadora portatil). La versio actual (quan s'escrit esta ajuda es la 2.32) de PageDefrag de Sysinternals que no soporta Windows Vista i Windows 2008.

La declaracio anteriorment citada sobre Sysinternals no es totalment certa. En un disc BartPE i afegint el plug-in de JkDefragGUI que pot descarregar des de http://www.emro.nl/freeware. Pot desfragmentar el disc dur des de l'exterior del seu sistema operatiu i els archius anteriorment citats tambe seran desfragmentats.

Quan s'ha iniciat el GUI per primera vegada pagedefrag no esta disponible fins que es descarregue del lloc de Microsoft. Durant l'inici li preguntaran si vol descarregar Pagedefrag. Pot seleccionar Si, No o Cancelar. Si tria Si es descarregaran e instalaran les opcions de pagedefrag en el GUI. Si selecciona No, no li preguntara un atra vegada si vol descarregar pagedefrag, voreu en la seccio de preguntes FAQ . Si selecciona Cancelar, li tornara a preguntar un atra vegada despres de reiniciar el programa.


Netejador

Pesta nye s de la GUI - Netejador

JkDefragGUI pot fer una neteja basica del seu perfil d'usuari o pot netejar els perfils de tots els usuaris marcant totes les carpetes que vullga, pero tindra que tindre permisos sobre totes les carpetes dels perfils.

La carpeta Prefetch es utilisada per Windows XP per afanyar-se en el proces d'arranc. Windows XP registra l'informacio de cada programa que llança el sistema d'arranc i utilisa l'informacio per a iniciar-se mes rapidament la proxima vegada. Com multiples archius poden tindre el mateix nom aço afegix un "hash" de la posicio de l'archiu. Aço es una rara cadena de numeros i cartes entre el nom de l'archiu i l'extensio .pf. Esta carpeta pot acumular archius inutils, sobre tot si voste canvia molt sovint la seua configuracio. No fara ningun mal si buida aço. Windows heu reconstruira quant siga necessari.

L'optimisacio del Registre crida a un programa extern NTREGOPT. L'optimisacio feta per NTREGOPT simplement compacta les celes del registre per a minimisar el seu tamany.

Totes estes opcions excepte l'optimisacio del Registre, poden sobreescriures per l'opcio "Utilisar CCleaner" de la pestanya "Opcions -> Varios", esta opcio nomes esta disponible quan l'eixecutable CCleaner.exe i l'archiu de la seua configuracio “ccleaner.ini”, son copiats manualment en la carpeta "Programs".


Wash

Pestanyes de la GUI - Llavant

JkDefragGUI tambe pot borrar senyes del seu disc dur que voste pensa que ya no existixen. Algunes ferramentes de recuperacio de disc poden recuperar archius que s'han borrat vaig Windows, encara que hages formatejat el disc dur els archius es poden recuperar. La funcio Llavant ompli el seu disc dur de senyes aleatories i fara mes dificil recuperar eixos archius. Quan voste repetixca varies vegades el procediment sera impossible recuperar eixos archius. Aço aumentara la seua privacitat.


Menu
  • Archiu
  • Vore
  • Idioma
  • Configuracio
  • Ajuda


Archiu

Men u - Archi u

  • Eixecutar desfragmentador - Aço iniciara JkDefrag en les opcions que voste haja seleccionat en la GUI
  • Llegir registre - Lligga el registre d'events creat per JkDefrag des de dins de la GUI
  • Eixir - Ix de JkDefragGUI


Vore

Men u - V ore
  • Mostrar instalador - Quan tria la pestanya de l'instalador es fa visible d'un atra manera no sera visible.
  • Mostrar programador - Quan tria la pestanya del programador es fa visible d'un atra manera no sera visible.
  • Mostrar sistema - Quan tria la pestanya del sistema es fa visible d'un atra manera no sera visible.
  • Mostrar netejador - Quan tria la pestanya del netajador es fa visible d'un atra manera no sera visible.
  • Mostrar llavant - Quan tria la pestanya llavant es fa visible d'un atra manera no sera visible.
El menu vore no es mostrara en el modo BartPE.


Idioma

Men u - Idioma

JkDefragGUI soporta varis idiomes que voste pot triar en el menu d'idioma. L'idioma seleccionat es guardat en JkDefragGUI.ini. S'utilisen les següents abreviatures.

Idioma | Abreviatura
Alemà | DE
Anglés | EN
Brasileny | BRP
Bulgar | BU
Català | CA
Chec | CZ
Chinenc Simplificat | ZH2
Chinenc Tradicional | ZH1
Croat | HR
Eslovac | SK
Eslové | SL
Espanyol | ES
Francés | FR
Grec/ Helenic | GR
Hebreu | HE
Holandés | NL
Hungar | HU
Indonesi | INA
Italià | IT
Japones | JP
Polac | PL
Portugués | PT
Rumà | RO
Rus | RU
Servi | SR
Suec | SE
Turc | TR
Ucranià | UA
Valencià | VA


Ajusts

Menu - Configuracio
  • Guardar configuracio - Guardara totes les opcions que ha seleccionat en la GUI
  • Restaurar configuracio - Aço restaurara totes les opcions a les que venien per defecte en la GUI
  • Copiar configuracio al portapapers - Copia totes les opcions seleccionades de JkDefrag al portapapers


Ajuda

Men u - A j uda
  • Lloc web de Jeroen Kessels
  • Lloc web de EMRO Automatisering
  • Lloc web de Sysinternals
  • Lloc web de Lars Hederer
  • Ajuda – Este archiu d'Ajuda
  • Credits - Donat-li les gracies a totes les persones que m'Ajuden en la traduccio o desenrollament de JkDefragGUI
  • Lllegir l'historial de canvis - Lligga els canvis de cada versio de JkDefragGUI
  • Colors de JkDefrag - Explicacio dels colors utilisats per JkDefrag.
  • Comprovar en busca d'actualisacions - Comprova manualment les actualisacions de JkDefragGUI i JkDefrag.


Bandeja de sistema

L'icon de la bandeja del sistema de JkDefragGUI te sis opcions

  • Reiniciar transparencia - Restaura la transparencia triada
  • Detindre JkDefrag.exe - Dete la versio que esta en eixecucio de JkDefrag.exe
  • JkDefrag Colors - Explaination of the colors used by JkDefrag
  • Eixecutar - Inicia JkDefrag en les opcions que voste tinga seleccionades en la GUI
  • Eixir - Ix de JkDefragGUI, pero aço no detindra inmediatament al JkDefrag.exe que s'estiga eixecutant
  • Començar Llavant - Borra senyes confidencials de l'espai lliure del seu disc dur


Tecl e s d'acces r a pi t

Tecla | Descripcio curta | Descripcio llarga
F1 | Ajuda | Mostra este archiu d'ajuda
F3 | Guardar configuracio | Guarda totes les opcions triades a un archiu de configuracio
F4 | Copiar la configuracio al portapapers | Copia totes les opcions triades de JkDefrag al portapapers
F5 | Eixecutar desfragmentacio | Aço eixecuta JkDefrag en les opcions configurades en la GUI
F6 | Llegir archiu de registre | Obri l'ultim archiu de registre
F7 | Guardar archiu de registre | Aço li mostrara una finestra per a guardar l'archiu de registre en un atre lloc
F8 | Imprimir archiu de registre | Aço li mostrara automaticament una pantalla en les impressores instalades i li permetra imprimir l'archiu de registre
F9 | Llavar unitat de disc | Borra senyes confidencials de l'espai lliure del disc dur triat
F10 | Eixir | Finalisa JkDefragGUI
F11 | Netejar Sistema | Llevar archius temporals i fer un atra neteja
F12 | Comprovar actualisacions | Revisa manualment si hi ha una actualisacio de JkDefragGUI o JkDefrag


Ll i nea de comandos

JkDefragGUI pot ser eixecutat en quatre parametros

/h i /hs, son dos parametros que inicien JkDefrag en les opcions guardades per la GUI i eixecuta JkDefrag sense ser mostrat a l'usuari. La diferencia entre /h i /hs es que /hs pot apagar l'ordenador quan la defragmentacio ha finalisat o el proces finalisa. El modo ocult esta nomes disponible en estos parametros.

/s aço auto seleccionara "apagar l'ordenador despres de defragmentat" en la GUI.

/r aço eixecutara automaticament JkDefrag en opcions de guardat inclus la neteja i la funcio llavant.

/rs lo mateix que /r pero en l'apagat de l'ordenador quant s'haja completat.

/d:x: selecciona l'unitat X: com a unitat predeterminada en la GUI.

/c:file comprova l'archiu de configuracio cridant a l'archiu de la carpeta config, aço sobreescriura els ajusts guardats en JkDefragGUI.ini

/reset, pot restaurar casi tot per defecte, archius d'ajuda, archius d'idioma, imagens, so i la configuracio, aixina com tambe pot fer-se seleccionant una opcio en la seccio "A l'inici" de la pestanya “Opcions”.

I per ultim /? mostrara l'ajuda de la llinea de comandos com en el següent quadro.


Program e s externs

  • JkDefrag
  • JT
  • Pagedefrag
  • NTREGOPT
  • CCleaner

    • © Emiel Wieldraaijer 2007/2008


JkDefrag

Program e s externs - JkDefrag

Desfragmentador i optimisador de discs, debades i lliure (lliberat baix la Llicencia Publica General de GNU) utilitat per a Windows 2000/2003/XP/Vista/X64. Completament automatic i molt facil d'usar, rapit, de baix consum, en varies estrategies d'optimisacio, pot manejar disquets i discs USB. Inclos en una versio per a Windows, una versio de llinia de comandos (per a programar per l'Administrador de tarees o per a l'us de l'administrador mijant un scripts), una versio de salvapantalles, una llibreria DLL (per a usar en atres llenguages de programacio), i versions per a Windows X64.

JkDefrag es un desfragmentador de discs que s'iexecuta segons es necessita o en modo automatic per mija dels parametros de llinea de comando o integrat al salvapantalles. Per defecte, el programa usa una "Optimisacio rapida", dissenyada per a tots els dies, pero tambe soporta parametros personalisats que poden moure els archius fins al final (o el principi) del disc, els pot ordenar per nom, tamany i atres criteris. Si be JkDefrag pot ser administrat en una GUI estandart de Windows, la major part d'eixes poderoses caracteristiques son dirigides a usuaris que estan familiarisats en l'us de la llinea de comandos. JkDefragGUI va ser creada per a persones que no tenen les habilitats d'un usuari avançat i que vullguen poder utilisar estes poderoses caracteristiques o per a eixes persones que els agrada una GUI en lloc d'una llinea de comandos.

JkDefrag no conte cap programa adware o spyware.

Per a mes informacio visite el lloc web de Jeroen Kessels: http://www.kessels.com


JT (Task Scheduler)

Program e s externs - JT

JkDefragGUI te la capacitat de programar desfragmentacions. JkDefragGUI utilisa un programa extern. Microsoft ® Task Scheduler Command Line Utility "JT.exe" es un conjunt d'utilitats de Windows 2000. JT.exe es compatible en NT/2000/2003/XP/Vista.

Voste pot descarregar JT.exe des de ftp://ftp.microsoft.com/reskit.


Pagedefrag

Program e s externs - Pagedefrag

Una de les llimitacions de l'interfaç de desfragmentacio de Windows NT/2000 es que no es possible desfragmentar archius que son oberts per a un acces exclusiu. Aixina, els programes estandart de desfragmentacio no li poden mostrar com de fragmentats o desfragmentats estan els archius de paginacio o archius de Registre. La fragmentacio de l'archiu de paginacio i Registre poden ser una de les causes principals de la degradacio del funcionament d'un sistema.

PageDefrag utilisa tecniques avançades que desfragmentadors comercials no tenen: L'habilitat de vore com de fragmentats estan els archius de paginacio i de Registre, i per a desfragmentar-los. Ademes, els archius de registre d'events de desfragmentat i els archius d'hivernacio de Windows 2000/XP (on la memoria del sistema se guarda quan voste hiverna un ordenador portatil).

PageDefrag treballa en Windows NT 4.0, Windows 2000, Windows XP, i Server 2003.

Per a mes informacio visite el lloc web: http://www.microsoft.com/technet/sysinternals/default.mspx


NTREGOPT

Program e s externs - NTREGOPT

JkDefragGUI inclou un atra ferramenta fantastica que s'anomena NTREGOPT. Es una chicoteta ferramenta d'Optimisacio del Registre que esta dissenyada per a Windows NT/2000/2003/XP. El programa esta fet per Lars Hederer i la versio inclosa es la 1.1j del 10/20/2005. Per a atres bons programes de Lars Hederen visite el seu lloc web: http://www.larshederer.homepage.t-online.de

Introduccio

Similar al Windows 9x/Me, l'archiu de registre en un sistema basat en NT pot fragmentar-se en el pas del temps, ocupant mes espai en el disc dur de lo que es realment necessari i decreixent el rendiment del sistema. Voste deuria utilisar l'utilitat NTREGOPT regularment, pero especialment despres d'instalar o desinstalar un programa, minimisa el tamany dels archius del registre i optimisa l'acces al registre. El programa treballa recreant cada cela del registre "des de zero", aixina lleva qualsevol espai buit que pot quedar de claus previament modificades o borrades. Tinga en conte que el programa no modifica el contingut del registre de ningun modo, ni desfragmenta físicament els archius del registre en el disc (com ho fa el programa PageDefrag de SysInternals). L'optimisacio feta per NTREGOPT simplement compacta les celes del registre per a minimisar lo mes possible el seu tamany.

Sistemes operatius soportats

Windows NT 3.51- Windows NT 4.0- Windows 2000- Windows 2003- Windows XP- i probablement mes, totes les versions futures de Windows basades en l'instalacio del kernel de NT

Parametros de la llinia de comandos de NTREGOPT

NTREGOPT soporta parametros de la llinia de comandos en els que voste pot realisar una optimisacio "silenciosa" del registre, sense interaccio de l'usuari.

La sintaxis per a la llinia de comandos de NTREGOPT es:

NTREGOPT silent [/noprogresswindow] [/reboot] (Els parametros entre corchets son opcionals.)

Descripcio dels parametros de la llinia de comandos:

  • silent, posa NTREGOPT en el modo "silencios" i permet els atres parametros\
  • /noprogresswindow, oculta la finestra de progres durant l'optimisacio.
  • /reboot, automaticament reinicia l'ordenador quan l'optimisacio del registre s'ha completat.

Problemes coneguts

NTREGOPT algunes vegades falla en erro 1450 - "No existixen recursos suficients en el sistema per a completar el servici demanat " - a l'intentar guardar una cela optimisada del registre. Yo encara no he pogut reproduir este erro en cap d'ordenador personal, i els informes d'usuaris afectats senyalen que algunes vegades tambe falla a l'intentar fer una copia de seguritat d'una cela critica utilisant el programa REGBACK de Microsoft. Aço fa impossible que yo puga fer res per evitar-lo (el programador). Alguns usuaris reportaren que pugueren evitar el problema eixecutant NTREGOPT en el modo segur de Windows, i en un cas desinstalant una suite del software Symantec solucionat el problema permanentment. Un usuari reporta que incrementant el valor "IRPStackSize" com esta descrit en l'articul Microsoft Knowledge Base 177078 va corregir el problema en el seu sistema. Quan el sistema es reiniciat despres d'una optimisacio en NTREGOPT, Windows Server 2003 per defecte mostrara el rastrejador d'events d'apagat durant l'entrada en el sistema preguntant per que el sistema s'apagat inesperadament. Aço es perque l'informacio de l'apagat va ser escrita en la copia "vella" del registre durant l'apagat del sistema es va reemplaçar per la copia del registre optimisada despres el sistema es va reiniciar, i per aixo l'informacio de l'apagat es descartada i el rastrejador d'events d'apagat pensa que el sistema ha fallat. Voste pot voler desactivar al rastrejador per a evitar este mensage en el futur (veja l'ajuda de Windows per a major informacio sobre com fer aço). Si voste experimenta algun atre problema, per favor enviar-me un email en una descripcio detallada i yo vore si li puc ajudar.

Localisacio

Voste pot traduir este programa al seu idioma editant l'archiu NTREGOPT.LOC. Tinga en conte que l'archiu deuria ser editat utilisant un editor basat en Windows (el Bloc de Notes), per a assegurar-se que qualsevol caracter OEM es mostrat correctament en el programa. Si el seu idioma no esta encara present en la meua plana web i voste vol que el seu idioma estiga disponible per al public general, es benvingut a enviar-me la seua traduccio. Llavors la posare disponible per a la seua descarrega, en credits per supost. He inclos un archiu de l'idioma alemà. Si vostes volen utilisar el programa en alemà, simplement descomprixca l'archiu LOC_GER.ZIP en la seua carpeta de NTREGOPT.

Historial de versions

NTREGOPT v1.1j - 10/20/2005

- Fixed compatibility issues with 64-bit Windows (many thanks to Ian Smith and Hajo for all testing)

- Enhanced error messages

NTREGOPT v1.1i, - 08/17/2005

- Optimization results are now calculated correctly when optimization failed on one or more hives

NTREGOPT v1.1h - 03/06/2005

- Updated homepage address

NTREGOPT v1.1f - 08/26/2004

- Window position is now screen center instead of desktop center, fixing display problem when using multiple monitors (thanks John :)

NTREGOPT v1.1e - 07/31/2004

- Optimization results: use thousand separator

NTREGOPT v1.1d - 07/07/2004

- Optimized error handling

NTREGOPT v1.1c - 05/10/2004

- Fixed problems with dynamic disks

- Re-added support for Windows NT 3.51 (got lost with v1.1)

NTREGOPT v1.1b - 04/23/2004

- NTREGOPT is now compatible with Windows Server 2003 and Windows XP Service Pack 2

- Fixed a problem where the registry hives could not be optimized on some systems

NTREGOPT v1.1a - 10/03/2002

- Fixed a problem where the registry hives could not be optimized on some systems

NTREGOPT v1.1, 09/25/2002

- Added command line support- Show optimization results (initial and new registry size)

NTREGOPT v1.0 - 11/24/2001

- Initial release

Distribucio

El programa NTREGOPT es debades. Per favor pasel a qualsevol que voste pense que li pot resultar util. Yo explicitament permet que este programa siga inclos en qualsevol archiu comprimit, CD-ROM o un atre mija, aixina com tambe coleccio de programes en tal que tots els archius no siguen modificats i permaneixquen inalterats. Una nota rapida per email on el meu programa haja sigut inclos es d'agrair.

Donacions

Encara que vaig triar fer el meu programa debades a fi de que ningu estiga obligat a pagar per utilisar-lo, accepte i aprecie les donacions. Llavors, si vostes troben els meus programes utils i volen donar soport a mes desenrollaments, simplement visite la meua plana web i aprete sobre el boto "PayPal", o done directament a la meua direccio de correu electronic per mijant de PayPal. ¡Gracies anticipades! Si voste viu en Alemania i vol fer una donacio, tambe pot transferir diners directament al meu conte corrent. Contacte en mi per a mes informacio.

Descarrega de responsabilitats

Use this software at your own risk. I do not take responsibility for anything that might happen to you or the PC upon use of my program, including but not limited to: registry destruction, hard disk crash, heart attack...

Valencià

Utilise este software baix la seu responsabilitat. No em faig responsable de ninguna cosa que li puga ocorrer a voste o al seu ordenador personal en l'us del meu programa, incloent pero no llimitant-se a: destruccio del registre, del disc dur, atac al cor...

Comentaris i sugerencies per email, ¡no obstant, son sempre benvinguts!


CCleaner

Program e s externs - CCleaner

Esta informacio de CCleaner esta basada a partir de la versio del 30 de Juliol del 2008

JkDefragGUI te un netejador pero es molt simple. Hi ha un mes avançat disponible en Internet i el seu nom es CCleaner. CCleaner es un producte de Piriform i te mes d'una cosa en comu en JkDefrag. Permet a Windows funcionar mes rapit, mes eficaçment. Es un programa menut, debades i no conte adware.

Resum del Programa:

Neteja els següents components de Windows i molt mes :

  • Internet Explorer
    - Archius temporals d'Internet
    - Historial URL
    - Cookies
    - Borrar archius Index.dat
    - Ubicacio d'ultimes descarregues
    - Formularis autocompletat
  • Firefox
    - Archius temporals d'Internet
    - Historial URL
    - Cookies
    - Historial de descarregues
  • Opera
    • - Archius temporals d'Internet
    - Historial URL
    - Cookies
  • Buidar Paperera
  • Portapapers
  • Archius temporals de Windows
  • Archius de registre de Windows
  • Documents recents (en el menu Inici)
  • Eixecucions (en el meu Inici)
  • Historial de l'assistent de busca de Windows
  • Senyes antigues e Prefetch
  • Descarregues de memoria de Windows
  • Fragments d'archius de Chkdsk

Les opcions avançades permeten la neteja de:

  • Cache de disposicio de menu
  • Cache de notificacio de Bandeja
  • Cache de tamany/ubicacio de finestres
  • Historial d'assistencia a l'usuari
  • Archius de registre de IIS
  • Personalisar archius i carpetes

Neteja per aplicacions:

Aixi com la neteja de vells archius i antigues configuracions de components de Windows, CCleaner tambe neteja archius temporals i llistes d'archius recents per a moltes aplicacions. Inclusive:

  • Firefox, Opera, Safari, Media Player, eMule, Kazaa, Google Toolbar, Netscape, Microsoft Office, Nero, Adobe Acrobat Reader, WinRAR, WinAce, WinZip i mes ...

Neteja del Registre:

CCleaner utilisa una neteja avançada del Registre per a revisar en busca de problemes e inconsistencies. Pot comprovar els següents:

  • Extensions d'archiu invalides
  • Controls ActiveX
  • Controls ClassIDs
  • ProgIDs
  • Desinstaladors
  • DLLs compartides faltants
  • Fonts
  • Referenciens d'archius d'Ajuda
  • Rutes de l'aplicacio
  • Icons
  • Accesos directes invalits i mes...

Seguritat:

CCleaner es va dissenyar per a ser segur i segur per a utilisar-se. Te varios nivells de comprovacions per assegurar que no pot borrar cap d'informacio i documents utils que voste puga necessitar. Tambe certifiquem que aço no conte cap de Spyware o Adware.

Alta Seguritat:

Per als usuaris super cautelosos tambe oferim el borrat segur de l'archiu. Sobreficant els archius abans de borrar-los, fent impossible la recuperacio de les senyes.

Multiples idiomes:

Gracies als traductors, CCleaner esta disponible en 35 idiomes diferents

English, Albanian, Arabic, Bosnian, Bulgarian, Catalan, Chinese (Simplified), Chinese (Traditional), Czech/Slovak, Danish, Dutch, Finnish, French, Galician, German, Greek, Hebrew, Hungarian, Italian, Japanese, Korean, Lithuanian, Macedonian, Norwegian, Polish, Portuguese, Portuguese (Brazilian), Romanian, Russian, Serbian Cyrillic, Serbian Latin, Slovak, Spanish, Swedish and Turkish.

Per a mes informacio visite el seu lloc web : http://www.ccleaner.com


Servici i Soport

Servici i Soport - JkDefragGUI per defecte
  • Preguntes mes freqüents (FAQ)
  • JkDefragGUI per defecte
  • Estructura de carpetes


Preguntes mes freqüents (FAQ)

Servici i Soport – Pregunt e s m e s fre qü ents (FAQ)

Preguntes

  1. El meu idioma no esta disponible en la GUI, ¿puc afegir el meu?
  2. ¿Puc programar una tarea remotament en JkDefragGUI ?
  3. Els archius d'idioma estan danyats, ¿que puc fer?
  4. Utilise el programador de tarees incorporat pero quan torne a arrancar JkDefragGUI els ajusts s'han restablit, ¿que esta mal?
  5. ¿Com puc usar CCleaner en lloc del netejador incorporat?
  6. Quan JkDefrag esta eixecutant-se, JkDefragGUI s'eixecuta en segon pla. ¿Se pot eixir de JkDefragGUI ?
  7. ¿Me pot donar voste algun atre consell?
  8. He trobat un fallo, ¿que puc fer?
  9. Despres d'utilisar la funcio llavant ya no queda espai en el disc, ¿que ha passat?
  10. ¿Puc llevar archius d'ajuda no usats?
  11. ¿ Pagedefrag no esta disponible en la GUI perque s'ha enganyat ?

1. ¿El meu idioma no esta disponible en la GUI , ¿ puc afegir el meu?

Voste pot , editar l'archiu user.lng de la carpeta de "languages". Lo mes important es canviar el "&User" que activara l'idioma creat per l'usuari este text se mostrara en el menu d'idiomes. No canvie els valors entre [ ] nomes canvie el text despres d'ells. Si voste vol compartir l'idioma en la resta del mon i estaria dispots a mantindre l'archiu de llenguage, per favor siga tan amable d'enviar-me una copia del seu idioma. Voste el pot enviar per correu electronic a emielwieldraaijer@hotmail.com

Tornar amunt

2. ¿Puc programar una tarea remotament en JkDefragGUI?

No, JkDefragGUI no soporta programacio remota en un atre ordenador tal vegada esta caracteristica s'afegira en un futur.

Tornar amunt

3. Els archius d'idioma estan danyats, ¿que puc fer?

Ixga de JkDefragGUI i borre tots els archius de la carpeta "languages", torne a arrancar el programa.

Tornar amunt

4. Utilise el programador de tareas incorporat pero quan torne a arrancar JkDefragGUI els ajusts s'han restablit, ¿que esta mal?

Els ajusts en la pestanya de l'Administrador s'utilisen nomes per a programar la desfragmentacio. No mostra les opcions de les tarees programades. Si voste vol canviar els ajusts tindra que guardar la configuracio. Voste pot guardar la configuracio pulsant la tecla F3 o en el menu "Configuracio" pulsat "Guardar configuracio"

Tornar amunt

5. ¿Com puc utilisar CCleaner en lloc del netejador incorporat?

Instale CCleaner en el seu ordenador i copie els archius ccleaner.exe i ccleaner.ini en la carpeta "Programs" on estiga instalada la GUI. Una opcio adicional se mostrara en la pestanya "Opcions" seccio "Varios", anomenada "Utilisar CCleaner ". CCleaner sera usat, quan estiga marcada eixa caixa de verificacio.

Tornar amunt

6. Quan JkDefrag estiga eixecutant-se, JkDefragGUI s'iexecuta en segon pla. ¿Se pot eixir de JkDefragGUI?

Voste pot eixir de JkDefragGUI mentres JkDefrag s'iexecuta, clic dret sobre l'icon de JkDefragGUI en la bandeja del sistema i trie eixir (Clic esquerre pot configurar-lo per a fer lo contrari).

Tornar amunt

7. ¿Me pot donar voste algun atre consell?

  1. Neteje tots els archius vells del seu disc dur abans d'eixecutar JkDefrag
  2. Reinicie abans d'eixecutar JkDefrag. Aço lliberara archius que estiguen en us, aixina se podran desfragmentar.
  3. Detinga l'escaner de l'antivirus en temps real abans d'eixecutar JkDefrag. Els escaners de l'antivirus comproven tota l'activitat del disc, i la desfragmentacio i optimisacio sera molt llenta.
  4. Moga el swapfile a un atre volum o particio, reinicie, desfragmente, i torne a posar el swapfile on estaba. Si voste no te un segon volum o particio, llavors reduixca de tamany el swapfile, a 100MB per eixemple.
  5. Si una aplicacio (per eixemple una base de senyes) impedix desfragmentar certs archius llavors detinga JkDefrag, i eixecute-lo nomes per al directori particular d'eixes senyes, i torne a arrancar l'aplicacio.
  6. Faça un disc BartPE i utilise el Plugin BartPE, quan eixecuta JkDefragGUI en un ambient BartPE tots els archius es poden desfragmentar.

Tornar amunt

8. He trobat un fallo, ¿que puc fer?

Envie un email a emielwieldraaijer@hotmail.com, pose tanta informacio com li siga possible, Sistema operatiu, Idioma, Memoria i tota l'atra informacio. Si se li mostra un mensage d'erro per favor adjunte-lo al correu electronic. Per als que no saben com copiar el mensage: Pulse la tecla <Alt> i <ImpPant> aguantant les dos tecles al mateix temps, inicie el programa Paint que es troba en el menu Inici - accesoris i <ctrl> i <v> al mateix temps. Guarde l'image i adjunte-la al correu electronic. Per a obtindre informacio del seu sistema, tambe podria descarregar el programa SimpleSysInfo i pot triar el boto d'informacio del sistema, per a guardar l'archiu de text en tota l'informacio del seu ordenador i adjuntar-lo tambe al correu electronic (Per favor lleve la llinea en la seua informacio del numero de serie del seu sistema).

Tornar amunt

9. Despres d'utilisar la funcio llavant ya no queda espai en el disc, ¿que ha passat?

La funcio Llavant ompli el disc dur de senyes aleatories i quan no hi haja mes espai la basura sera borrada. A vegades l'archiu en la basura que s'almagasena en l'arrel del disc dur no es pot borrat. L'archiu s'anomena JkDefragGUI_Eraser.tmp i es pot borrar sense perill del disc dur. Este problema pot ser causat per virusscanners i recursos baixos del sistema. ).

Tornar amunt

10. ¿Puc llevar archius d'ajuda no usats?

Pot llevar els archius de la carpeta d'ajuda, excepte JkDefragGUI.chm. Si vols llevar JkDefragGUI.chm deus renomenar un atre archiu d'ajuda a JkDefragGUI.chm. Quan no s'ha trobat cap d'archiu d'ajuda d'un idioma particular s'usara l'anglés.

Tornar amunt

11. ¿Pagedefrag no esta disponible en la GUI perque s'ha enganyat?

Quan vas iniciar per primera vegada, havia una pregunta en quant a descarregat Pagedefrag. Si vas seleccionar No, Pagedefrag no es va descarregar i esta pregunta no es tornara a fer. Per a resoldre este problema reinicia els ajusts GUI predeterminats seleccionat la pestanya Opcions, en el boto d'inici seleccione "Preguntar un atra vegada si vol descarregar Pagedefrag a l'inici" o pot corregir JkDefrafGUI.ini canviat PageDefragDownload=NO a PageDefrafDownload=Si.

Tornar amunt


JkDefragGUI per defecte

Servici i Soport - JkDefragGUI p e r defect e

General per defecte
Idiomes |  | Per defecte l'idioma quan s'inicia per la primera vegada se basa en l'idioma del Sistema operatiu, sino sera l'angles .
Pestanya General
 | Accio | 3 - Analisar, desfragmentar i optimisacio rapida
 | Nivell de depuracio | 1 – Mensage d'avis
 | Unitat | C:
 | Tots els discs (caixa) | No marcada
 | Velocitat | 100 %
 | Espai lliure | 1 %
Pestanya Avançat
 | Incloure | Res posat
 | Excloure | Res posat
 | Moure estos archius al final. (Spacehogs) | Res posat
 | Utilisar archiu de registre | Marcat
 | Guardar l'archiu de registre en la carpeta de la GUI | No Marcat
 | Localisacio de l'archiu de registre | Carpeta temp de l'usuari actual
Pestanya Programador
 | Nom d'usuari | Usuari actual
 | Contrasenya | No visible pero es NULA, quan l'usuari actual no te ninguna contrasenya especificada
 | Hora | 23:59
 | Data | Data actual
 | Interval | Semana
 | Retart | 0
 | Dia | Dilluns (DI)
Instalador - Windows
 | Afegir GUI a l'inici de Windows | No Marcat
 | Crear acces directe en l' Escritori | Marcat
 | Crear carpeta en el menu Inici | Marcat
 | Crear acces directe en l'inici rapit | Marcat
 | Instalar JkDefragGUI en | Archius de programa \JkDefragGUI
Instalador - Salvapantalles
 | Interval d'espera | 10 minuts
 | Barra d'estat | Barra d'estat completa
 | No desfragmentar si la vegada anterior fa menys de X hores | 4
 | Alternatiu | Res posat
 | Llinea de comandos | Res posat
Sistema
 | En el següent reinici | No seleccionat
 | Cada reinici | No seleccionat
 | Conte arrere per a abortar la desfragmentacio | 3 (Agrissat)
 | No desfragmentar (desinstalar) | Seleccionat
Netejador
 | Usuari actual | Res Marcat
 | Tots els usuaris | Res Marcat
 | Buidar la carpeta temp de Windows | No Marcat
 | Buidar la carpeta prefetch | No Marcat
 | Optimisacio del registre | No Marcat
 | Buidar la Paperera en Tots els discs durs | No Marcat
Llavant
 | Repetir X vegades | 1
 | Triar tots els discs fixes | No Marcat
Opcions – A l'iniciar
 | Comprovar actualisacions a l'inici | No Marcat
 | Restaurar tot per defecte en el següent inici | No Marcat
Opcions - Dispositius
 | Detectar disc extraible | No Marcat
 | Mostrar disquet (si esta present) | No Marcat
 | Detectar ram disks | No Marcat
Opcions – A l'eixir
 | Borrar archiu de registre a l'eixir | No Marcat
 | Apagar despres de desfragmentar | No Marcat
 | Guardar configuracio a l'eixir | No Marcat
Opcions - Varios
 | Ocultar programador de tarees | No Marcat
 | Tancar JkDefrag quan haja finalisat | No Marcat
 | Spacehogs “Espai brut ” per defecte (archius > 50MB) | Marcat
 | Escoltar un so al finalisar | No Marcat
 | Borrar senyes de l'espai del disc no utilisat | No Marcat
 | Eixecutar l'opcio de neteja abans de desfragmentar | No Marcat
 | Utilisar CCleaner en el seu lloc (Vore Instruccions) | No Marcat


Estructura de carpetes

Servici i Soport – Estructura de carpet e s

Archius i Directoris |  | Descripcio
(Els archius de mes alt nivell)
JkDefragGUI.exe |  | El programa principal
JkDefragGUI.ini |  | L'archiu de configuracio usat per JkDefragGUI.exe
Changelog.txt |  | Veja el capitul Informacio de versio de JkDefragGUI
Readmefirst.txt |  | Archiu important que deuria llegir abans d'usar JkDefragGUI
Uninstall.exe |  | El desinstalador JkDefragGUI (nomes disponible si JkDefragGUI esta instalat)
Help (Ajuda)
 | JkDefragGUI.chm | Archiu d'ajuda en Angles
 | JkDefragGUI_ES.chm | Archiu d'ajuda en Espanyol
 | JkDefragGUI_NL.chm | Archiu d'ajuda en Holandés
 | JkDefragGUI_VA.chm | Archiu d'ajuda en Valencià
Languages (Idiomes)
 | brazilianportuguese.lng | Traduccio al Portugues Brasileny de JkDefragGUI
 | bulgarian.lng | Traduccio al Bulgar de JkDefragGUI
 | catalan.lng | Traduccio al Català de JkDefragGUI
 | croatian.lng | Traduccio al Croat de JkDefragGUI
 | czech.lng | Traduccio al Chec de JkDefragGUI
 | dutch.lng | Traduccio a l'Holandes de JkDefragGUI
 | english.lng | Traduccio a l'Angles de JkDefragGUI (Per defecte)
 | france.lng | Traduccio al Frances de JkDefragGUI
 | german.lng | Traduccio a l'Alemany de JkDefragGUI
 | hebrew.lng | Traduccio a l'Hebreu de JkDefragGUI
 | hellenic.lng | Traduccio al Grec/Helenic de JkDefragGUI
 | hungarian.lng | Traduccio a l'Hungar de JkDefragGUI
 | indonesian.lng | Traduccio a l'Indonesi de JkDefragGUI
 | italian.lng | Traduccio a l'Italià de JkDefragGUI
 | japanese.lng | Traduccio al Japones de JkDefragGUI
 | polish.lng | Traduccio al Polac de JkDefragGUI
 | portuguese.lng | Traduccio al Portugues de JkDefragGUI
 | romanian.lng | Traduccio al Ruma de JkDefragGUI
 | russian.lng | Traduccio al Rus de JkDefragGUI
 | serbian.lng | Traduccio al Serbi de JkDefragGUI
 | simplifiedchinese.lng | Traduccio al Chinenc Simplificat de JkDefragGUI
 | slovak.lng | Traduccio a l'Eslovac de JkDefragGUI
 | slovenian.lng | Traduccio a l'Eslove de JkDefragGUI
 | spain.lng | Traduccio a l'Espanyol de JkDefragGUI
 | swedish.lng | Traduccio al Suec de JkDefragGUI
 | traditionalchinese.lng | Traduccio al Chinenc Tradicional de JkDefragGUI
 | turkish.lng | Traduccio al Turc de JkDefragGUI
 | user.lng | Traduccio definida per l' usuari de JkDefragGUI
 | ukrainian.lng | Traduccio a l'Ucranià de JkDefragGUI
 | valencian.lng | Traduccio al Valencià de JkDefragGUI
Programs (Programes)
 | 7za.exe | La versio de llinea de comandos de 7-Zip usat per a extraure els archius al descarregar-los en el primer arranc i per a les actualisacions
 | 7za-readme.txt | Acort de llicencia de 7za
 | jkdefrag.exe | El programa de desfragmentacio principal usat per esta GUI
 | jkdefrag64.exe | La versio de 64bits de JkDefrag.exe
 | jkdefragcmd.exe | La versio de llinea de comandos de JkDefrag que es usada per l'administrador de tarees i per al modo ocult
 | jkdefragcmd64.exe | La versio de 64bits de JkDefragcmd.exe
 | jkdefragscreensaver.scr | El salvapantalles
 | jkdefragscreensaver64.scr | La versio de 64bits de jkdefragscreensaver.scr
 | jkdefragscreensaver.exe | L'eixecutable del salvapantalles
 | jkdefragscreensaver64.exe | La versio de 64bits de jkdefragscreensaver.exe
 | jt.exe | La ferramentea de planificacio en llinea de comandos de Microsoft Windows 2000
 | ntregopt.exe | L'Optimisador del Registre de Lars Hederer
 | ntregopt.loc | L'archiu d'idioma usat per ntregopt.exe
 | ntregopt.txt | Eula i documentacio de ntregopt.exe
 | pagedfrg.exe | PageDefrag de Sysinternals
 | pagedfrg.hlp | Archiu d'ajuda de PageDefrag
 | pagedfrg_eula.txt | EULA de sysinternals relatiu a PageDefrag
 | TimeOut.exe | Programar per a activar per temps un archiu de proces
Sounds (Sons)
 | finished.mp3 | Este so sera escoltat nomes quan JkDefrag ha finalisat la desfragmentacio (nomes quan estiga activat)


Informacio de Versio (Canviar registre)

Informacio de les versions

JkDefragGUI 1.03 - October 12th 2008

- Added JkDefrag.exe and other files to the archive, request of Jeroen Kessels
- Added a question to download JkDefrag when it isn't found in the program folder
- Added check to see if CCleaner is installed on local computer and update JkDefragGUI with it
- Added Ukrainian translation

- Added Turkish translation

- Added multiple logfiles support
- Added -s to commandline this will autoselect shutdown after defrag in the GUI
- Added -r to commandline this will automaticly run JkDefrag with saved options
- Added -rs to commandline this will automaticly run JkDefrag with saved options and shutdown afterwards

- Added read settings from scheduled job (only new onces)
- Changed JkDefragGUI Icon and TimeOut Icon

- Embedded background image into the executable

- Fixed bug Installer not working 100% when JkDefragGUI.exe is renamed

- Improved internal cleaner reading settings from all existing profiles
- Improved support CCleaner, internal cleaner can control CCleaner settings
- Improved deleting folders IECache and History current user, will not leave empty folders anymore
- JkDefragGUI not packed with UPX anymore to reduce the amount of false positives by virusscanning software
- Logfiles are saved with date and time in name and can be read from within the GUI

- Logfiles can be deleted from within the GUI

- Updated Uninstaller, a registry value was left behind

JkDefragGUI 1.02 - May 8th 2008

- Added automatic detection of indonesian language at first start of JkDefragGUI

- Added disk washing, replace erased information with garbage

- Added color help to tray menu

- Fixed bug CCleaner only executed when internal cleaner is selected before CCleaner

- Fixed bug LogFileAfterDefrag setting not set in the GUI after restart

- Fixed colors green switched in JkDefrag color help
- Fixed bug Serbian language not selected in language menu

- Fixed keylogger detection by some firewall applications

- Improved BartPE Support
- Improved and reduced code
- Made GUI Smaller when in BartPE Mode
- Removed external help files from GUI to reduce size of GUI executable
- Replaced external program wait.exe with selfmade one
- Some typo corrections in multiple language files

JkDefragGUI 1.01 - January 31st 2008

- Added automatic update of the scheduled job with newest jkdefrag when downloaded
- Added automatic update of the installed version with newest jkdefrag when downloaded
- Added croatian translation

- Added indonesian translation
- Added option to add a delay when doing a schedule at logon
- Added option to show logfile after defragmentation (GUI only)

- Added pagedefrag to the U3 version of JkDefragGUI
- Added empty prefetch folder to internal cleaner

- Added jkdefrag history to menu
- Fixed helpfile not displayed on network drive
- Fixed bug JkDefrag version not updated when updated through automatic update at startup
- Fixed bug "Show System" selected on startup when disabled
- Fixed bug spacehogs disabled when selected and enabled when not selected

- Fixed bug scheduled job logfile not saved when using folder with spaces
- Fixed bug calendar not displayed correctly on Vista OS

- Improved U3 version no need re-download JkDefrag on every usage
- Removed screensaver copied to system32 during update when not installed

- Removed some external links in help menu from BartPE Mode

JkDefragGUI 1.00 - December 1st 2007

- Added DisableDefaults spacehogs to hidden mode
- Added valencian translation
- Added hebrew translation
- Added play sound when finished option
- Added save settings on exit option
- Added windows cleaning (Temp/Cookies/History/Recent/RecycleBin)
- Added registry optimizer from Lars Hederer
- Added commandline /hs runs JkDefrag hidden and shutdown after defrag
- Added commandline /reset will reset JkDefragGUI to it's defaults and restore the language files
- Added support for CCleaner /Auto

- Added english helpfile
- Added spanish helpfile
- Added dutch helpfile

- Added valencian helpfile

- Added JkDefrag version info to statusbar of GUI
- Changed downloading PageDefrag, downloaded when JkDefragGUI is started for the firsttime
- Changed combobox screensaver, made readonly
- Created a new icon for JkDefragGUI
- Fixed bug automatic download and update of JkDefrag not working 100%
- Fixed bug no logfile created with taskschedular when path with space is used
- Fixed bug debuglevel not displayed correctly in GUI
- Fixed bug monthly schedule not saved correctly
- Fixed bug when password is cleared in password field from scheduler tab scheduled job not working
- Fixed bug with "All disk" selection not released when run second time without restart
- Fixed bug email link not working on X64
- Fixed bug downloading JkDefrag.exe update
- Fixed bug wrong icon in controlpanel software
- Improved Pagedefrag options
- Improved downloading JkDefrag.exe when starting the GUI for the first time
- Improved program which checks for the existance of an U3 Device
- Improved installer function to auto install pagedefrag and jkdefrag
- Improved X64 support
- Removed "Shutdown after defrag" option from BartPe mode
- Removed automaticly check for update function from BartPE mode

JkDefragGUI 0.94 - 16 September 2007

- Fixed bug not working on Windows Vista when User Account Control (UAC) is active

JkDefragGUI 0.93 - 14 September 2007

- Corrected small typo in spacehogs explanation in all language files
- Fixed bug logfile path not restored to temp folder when settings are reset to default
- Fixed bug language files are always overwritten
- Dutch language corrections made by Alfred Spijker

JkDefragGUI 0.92 - 10 September 2007

- Added czech translation
- Added slovak translation
- Added serbian translation
- Added language version check to overwrite old languages if found
- Added drivespace check when using the installer
- Added deleting pagedfrg.zip from the temp folder after download
- Added installer to the U3 version of JkDefragGUI
- Added scheduler to the U3 version of JkDefragGUI
- Added versioncheck for PageDefrag with Vista, version 2.32 and below has no Vista support
- Added update check for JkDefrag
- Added automatically updating JkDefrag en JkDefragscreensaver when update is downloaded
- Added all the missing items to the scheduler (Include/Exclude/Spacehogs)
- Added selecting language for the first time based on OS language
- Added missing color icon in BartPE mode
- Added missing transparency to changelog GUI
- Changed credit menu now smaller and scrolling
- Changed from RAR archive to ZIP archive
- Changed JK icon to new JkDefrag Icon
- Changed log file location in command line
- Improved X64 Support
- Improved GUI Speed
- Increased the calendar size for Windows 2000
- Increased the calendar size for Bulgarian regional settings
- Fixed bug error message when no internet connection detected during download PageDefrag
- Fixed bug importing shutdown settings from old ini file
- Fixed bug uninstaller not in selected language due to moved languages to folder languages
- Fixed bug tray item transparency state not set correct when closed through tray option
- Fixed bug JkDefragGUI not showing sometime when internet explorer is active
- Made uninstaller Unicode compatible
- No restart needed anymore when adding a tab
- Reduced memory usage
- Reduced CPU usage
- Removed JkDefrag from the JkDefragGUI.exe files downloaded automaticly
- Removed Sysinternals image from JkDefragGUI.exe due to copyright
- Removed background image from BartPE version
- Small cosmetic changes to scheduler checkboxes
- Supports only JkDefrag 3.17 and higher

JkDefragGUI 0.91 - 17 July 2007

- Corrected some typos in several languages
- Fixed bug error message when switching language on a Windows 2000 system
- Fixed bug running PageDefrag from folder with spaces
- Fixed bug saving "Select all fixed disks", disk selection not greyed out after restart
- Removed support for JkDefrag 3.15 and below
- Removed action 4, no longer supported by JkDefrag

JkDefragGUI 0.9 - 14 July 2007

- Made JKDefragGUI 100% Unicode compatible
- Added traditional chinese translation
- Added simplified chinese translation
- Added option to read the changelog in the GUI (English)
- Added shutdown after defrag option (Only GUI mode, not scheduler)
- Added disable default spacehogs option
- Added support for Sysinternals PageDefrag, downloaded automaticly when used
- Added selecting "Select all fixed disks" will disable single disk selection
- Added missing Spanish text "Include"
- Added exit JkDefragGUI through trayitem while defragging is active (Not with Shutdown Option)
- Added country flag icons to language menu and to the executable
- Added JkDefrag Colors to help section
- Added exclude, include and spacehogs (Move to end of data) to hidden mode
- Added download indicator to tray when downloading new version
- Added check for Windows Classic Theme to remove background image
- Fixed bug check for updates not saved correct in configuration file
- Fixed bug JkDefrag GUI freezes when update found at startup
- Fixed bug transparency not working 100% when running from U3
- Moved external programs to folder programs
- Moved languages files to folder languages
- Moved images used by the GUI to folder images
- No need for restart anymore when changing language
- Small cosmetic changes

JkDefragGUI 0.81 - 06 july 2007

- Updated JkDefragGUI to version 3.16
- Fixed bug Include/Copy to Clipboard not correct
- Fixed bug Action 11 = Analyze and sort files by creation time (oldest first) missing

JkDefragGUI 0.8 - 17 June 2007

- Updated JkDefrag to version 3.15
- Added Catalan translation
- Added Japanese translation
- Added Brazilian Portuguese translation
- Added Slovenian translation
- Added Russian translation
- Added Greek/Hellenic translation
- Added close JkDefrag when done defragging (-q option)
- Added move files to end (-u option)
- Changed program to use only external language files
- Corrected a color mismatch in the menu
- Fixed bug saving the selected installer not saved correctly to config file
- Fixed bug unable to save action 7, move to end as default
- Fixed bug exclude option not correctly copied to clipboard
- Fixed bug screensaver not replaced by newer version if older version exists
- Fixed bug task scheduler not working in Windows 2000
- Fixed bug selected language not made default when installing the GUI
- Fixed bug unable to start JkDefrag when running from U3
- Restarting the GUI made a bit faster when selecting another language
- Removed background image for Windows 2000 OS
- Removed the uninstall function of the Windows installer from the GUI
- Improved transparency to avoid colors in the GUI
- Some other minor Windows 2000 improvements

JkDefragGUI 0.7 - 28 April 2007

- Updated JkDefrag to version 3.8
- Added support for 64Bits JkDefrag
- Added Polish translation
- Added Bulgarian translation
- Added external language file support
- Added contextmenu
- Added an error message when pressing F6 and no logfile exists
- Added ability to change the path off the logfile
- Added option to disable logfile
- Added option to save logfile in GUI path
- Added option to delete logfile on exit
- Added windows installer/uninstaller
- Added the option to choose an alternative screensaver for JkDefragscreensaver installer
- Installing a newer version will create a backup of the old ini file
- Changed transparency slider to automatically set transparency (setting not saved automaticly)
- Fixed a bug in the Defrag Exclude function
- Removed fade-out on exit
- Removed user language from JkDefragGUI.INI
- Fixed bug user defined language not displayed correct
- Some code cleanup
- Some GUI improvements
- Some Vista improvements

JkDefragGUI 0.6 - 22 march 2007

- Made pull down menu read-only
- Some major changes in the GUI
- Removed balloontip from Show Scheduler
- Improved German translation
- Added more balloontips
- Added manual setting include files and folders
- Added Include and Exclude to save settings
- Added option to save logfile to alternate location
- Made logfile GUI resizable
- Added screensaver installer
- Added Hungarian translation
- Added Swedish translation
- Added options to copy command line to clipboard
- Added options to check for updates on every start of the GUI
- Fixed bug Selecting another language when run from folder with spaces Error
- Fixed bug pull down menu not compatible with Windows 2000

JkDefragGUI 0.5 - 6 March 2007

- Added Italian translation
- Added Romanian translation
- Added two more actions
- Added one more debug level
- Added free space option
- Added hidden mode from command line (Not 100% Perfect due to JkDefrag Close option)
- Added JkDefrag version 3.7 (Version 3.6 and lower will not work with GUI 0.5)
- Added Start date option to scheduler
- Added hide scheduled task and JkDefrag
- Added settings are applied to scheduler
- Added manual setting exclude files and folders
- Added hotkeys
- Added icons to GUI menu
- Added transparency to help and credit GUI
- Removed edit function from logfile
- Fixed bug task scheduler not working when JkDefrag is placed in a folder with spaces"
- Fixed bug reading a large logfile, logfile GUI not showing anything
- Fixed bug scheduler not working when no password is specified

JkDefragGUI 0.41 - 26 February 2007

- Fixed a bug JkDefrag not showing sometime
- Fixed a bug Scheduler not working when using an username with spaces

JkDefragGUI 0.4 - 24 Februari 2007

- Added USB, Floppy and Ramdisk support, drives are selectable
- Added task scheduler (Will be disabled in U3 or BartPE mode)
- Added manual save settings (even Scheduler Time/Interval/Days)
- Added restore settings to default
- Added transparency to JkDefrag and JkDefragGUI
- Added fade-out on exit
- Added Portuguese translation
- Fixed bug in User defined language JKDS050 not set
- Fixed bug wrong version saved in inifile when ini file is created
- Fixed bug wrong action selected when selecting Analyze, defragment and fast optimization

JkDefragGUI 0.3 - 11 Februari 2007

- Embedded logfile into the program
- Added printing the logfile from within program
- Added BartPE/XPE compatibility to same Executable
- Added the possibility to run JkDefragGUI from a read-only environment
- Added selecting all hard disk to defrag
- Added automatic importing old ini file and writing a new one

JkDefragGUI 0.2 - 30 January 2007

- Added four languages (Deutch/Español/Francais/Nederlands)
- Added possiblitly to add your own language (See created ini file in the same folder)
- Added update function
- Added file version and information to Executable
- Changed icon
- Created a separate Executable for BartPE/XPE
- Made JkDefragGUI 0.2 U3 Compliant

JkDefragGUI 0.1 - 16 January 2007

- Initial Release

© Emiel Wieldraaijer 2007/2008

Website : http://www.emro.nl/freeware / Email : emielwieldraaijer@hotmail.com

Revision 1.03


Cr e dits

Ante tot m'agradaria donar-li les gracies a Jeroen Kessels que es l'autor de JkDefrag.

Gracies a tota la gent que me reporta fallos i/o dona sugerencies per a millorar JkDefragGUI.

Pero en especial gracies a tot el mon que m'ajudat a traduir la GUI al seu propi idioma.

Idioma soportat | Traductor (Gracies per ajudar-me) | Versio i superiors
Alemà Alemà | Guido Drehsen | 0.2
Anglés Anglés | Emiel Wieldraaijer | 0.1
Brasileny Brasileny | Bruno Eduardo | 0.8
Bulgar Bulgar | Rusi Dimitrov | 0.7
Català Català | Aniol Maria | 0.8
Chec Chec | Kamil Kroc | 0.92
Chinenc Chinenc Simplificat | Tony Yu | 0.9
Chinenc Chinenc Traditional | Tony Yu | 0.9
Croat Croat | Igor Hranilovic | 1.01
Eslovac Eslovac | Peter Zilak | 0.92
Eslové Eslové | Zoran Kovacevic | 0.8
Espanyol Espanyol | Manuel Montero | 0.2
Grec Grec/Helenic | Thanassis Katsageorgis & Xhmikos | 0.8
Francés Francés | Bernard Dechen | 0.2
Hebreu Hebreu | Arik Amitzur | 1.0
Holandés Holandés | Alfred Spijker | 0.93
Holandés Holandés | Emiel Wieldraaijer | 0.2-0.92
Hongarés Hongarés | Tibor Sarkany | 0.6
Indonesi Indonesi | Mario Ray Mahardhika | 1.01
Italià Italià | Giandomenico Gozio | 0.5
Japonés Japonés | Daisuke Barlog | 0.8
Polac Polac | Artur Napierala | 0.7
Portugués Portugués | Rui Morais | 0.4
Rumà Rumà | Laurentiu Anisie | 0.5
Rus Rus | Alexander Sidorkin | 0.8
Servi Servi | Bojan Miladinovic | 0.92
Suec Suec | Andreas Peterzen & Irfan | 0.6
Turc Turc | Offchu | 1.03
Ucranià Ucranià | Alexey Lugin | 1.03
Valencià Valencià | Vicent Adam | 1.0