Introduccion

JkDefragGUI versión 1.03

JkDefragGUIes una GUI “Interfaz Gráfica de Usuario” que le permite seleccionar fácilmente todas las características de JkDefrag, una herramienta de desfragmentación libre y gratis hecha por Jeroen Kessels que tiene mucho que ofrecer.

Pero este programa puede hacer bastante más.

JkDefragGUI puede programar una desfragmentación, instalando JkDefrag o el salvapantallas pero también puede hacer algún pequeño mantenimiento más en su ordenador. Puede usarse para programar una desfragmentación de sus archivos de sistema como el archivo de la memoria virtual "pagefile.sys" y del archivo del Registro. JkDefragGUI también soporta CCleaner que puede usarse en lugar de la función interna de limpieza.

También puede borrar cualquier información que pueda quedar en el espacio libre de su disco después de borrar los archivos. JkDefragGUI fue creado para personas que no tienen las habilidades de un usuario avanzado y les ayuda a usar las poderosas características que JkDefrag tiene que ofrecer o para esas personas que prefieren usar una Interfaz Gráfica del Usuario en lugar de la línea de comando.

JkDefragGUI es compatible con el formato U3 de las memorias USB y con el entorno de preinstalación BartPE.

© Emiel Wieldraaijer 2007/2008

Website : http://www.emro.nl/freeware / Email : emielwieldraaijer@hotmail.com

Revision 1.03


Licencia final de usuario (EULA)

JkDefragGUI EULA – Licencia final de usuario

JkDefragGUI es un programa gratis y se suministra tal como es, sin ninguna garantía.

Usted puede usar este programa bajo su propio riesgo.

El autor no es responsable de ningún daño causado por este programa.

JkDefragGUI puede ser distribuido libremente, a condición de que el paquete del programa no sea modificado.

Ninguna persona o empresa puede cobrar una retribución por la distribución de JkDefragGUI sin permiso escrito del autor


Introduccion

Introducción
  • Características principales
  • Requerimientos del sistema
  • U3
  • BartPe


Características principales
  • Desfragmenta su ordenador
  • Apaga su ordenador después de la desfragmentación
  • Ejecuta una desfragmentación oculta
  • Instalador de JkDefrag
  • Instalador del salvapantallas de JkDefrag
  • Programa una desfragmentación desde la GUI con las opciones que usted quiera
  • Instala y programa una desfragmentación de su archivo de paginación y del archivo de Registro
  • Limpia su ordenador
  • Optimiza y compacta su Registro
  • Automáticamente revisa en busca de una versión actualizada de JkDefrag
  • Borra los datos sensibles del espacio libre de su disco
  • Ver archivos de registro de JkDefrag


Requerimientos del sistema
  • S istemas operativos Windows 2000, Windows XP, Windows 2003, Windows Vista o Windows 2008
  • Un mínimo de 8 MB de espacio del disco


U3

JkDefragGUI es compatible con la tecnología U3.

Las opciones son guardas en la memoria U3 y se quedarán allí durante el uso de JkDefragGUI.

JkDefragGUI finaliza la desfragmentación cuando su memoria U3 es extraida o quitada de su sistema.

¡Almacene sus datos y lleve sus programas!

Imagine llevar sus programas en la misma unidad flash que lleva sus archivos. Eso es lo que usted puede hacer con un pequeño disco U3. Usted puede conectar su pendrive en cualquier PC, puede trabajar, jugar, enviar mensajes a sus amigos, enviar correo electrónico, puede editar fotos y desfragmentar o limpiar por completo su ordenador con JkDefragGUI. Un pequeño pendrive U3 hace de cualquier PC su propio ordenador personal. Y cuando usted lo desconecta, no deja atrás datos personales.

Vea más programas en U3 software central


BartPE

What is BartPE and PE Builder?

Bart PE Builder le ayuda a construir a un "BartPE" (Entorno Bart Preinstalado) un CD-ROM o DVD arrancable de Windows desde un CD de instalación original de Windows XP o Windows Server 2003, muy adecuado para tareas de mantenimiento del PC.

Le dará un entorno completo Win32 con soporte de red, una Interfaz Gráfica de Usuario de (800x600) y un sistema de ficheros FAT/NTFS/CDFS. Muy conveniente para grabar un sistemas de pruebas sin sistema operativo, para rescatar archivos de una red, escanear virus etc. Esto reemplazará cualquier disco de arranque.

Para más información acerca de BartPe visite el sitio web :http://www.nu2.nu o http://www.911cd.net/forums

Todas las funciones extra no están disponible en la versión BartPE de JkDefragGUI sólo las opciones del desfragmentador de Jeroen Kessels. La desfragmentación hecha a través de un CD o DVD BartPE tiene una gran ventaja: Ningún archivo está en uso así es que cada archivo puede ser desfragmentado.


JkDefragGUI

  • Pestañas de la GUI

  • Menú
  • Bandeja de sistema
  • Teclas de acceso rápido
  • Línea de comandos


Pestañas de la GUI
  • General
  • Avanzado
  • Opciones
  • Programador
  • Instalador
  • Sistema
  • Limpiador
  • Borrar espacio libre


General

Pestañas de la GUI - General

La pantalla general cubre los elementos básicos de JkDefrag

  • Acción - Use el menú desplegable para seleccionar una acción, la cual satisfaga su situación lo mejor posible.
  • Nivel de depuración - Use el menú desplegable para seleccionar el nivel de depuración de JkDefrag para el archivo de registro.
  • Disco - Usted puede seleccionar un disco de su elección o puede usar la casilla de verificación para seleccionar todos los discos fijos. JkDefrag soporta el desfragmentado de otros discos, pero por defecto está deshabilitado en la GUI. Usted puede habilitar estos dispositivos para revisar cambiando una opción en la sección “Dispositivos” de la pestaña de “Opciones”.
  • Velocidad – Es posible bajar la velocidad de JkDefrag para que consuma menos recursos del sistema. La velocidad normal tiene un valor de 100 y es la configurada por defecto.
  • Espacio libre - El tamaño del espacio libre se fija en N por ciento de (0... 100) del tamaño del volumen. El espacio libre son cuatro áreas del disco para archivos temporales. Hay 2 espacios libres, entre las 3 zonas (directorios, archivos normales y space hogs "espacio sucio"). Por defecto es el 1% (del espacio libre).

Cuando JkDefragGUI se inicia por primera vez la GUI usará las opciones predeterminados de JkDefrag.


Avanzado

Pestañas de la GUI - Avanzado

La pestaña avanzado gestiona los parámetro más avanzados que usted puede hacer con JkDefrag.

  • Incluir - Solo los archivos y/o directorios que coincidan con la máscara serán desfragmentados en lugar de la selección de discos de la pestaña general. Es posible añadir un disco a la opción incluir. Utilice comodines '*' y '?' en la máscara para que coincidan con un grupo de archivos o directorios. Algunos ejemplos: "*.avi","*\w3svc*\*.log","d:\mysql\data\*"
  • Excluir - Solo los archivos y/o directorios que coincidan con la máscara no serán desfragmentados y no serán movidos. Utilice comodines '*' y '?' en la máscara para que coincidan con un grupo de archivos o directorios. Algunos ejemplos: "*.avi","*\w3svc*\*.log","d:\mysql\data\*"
  • Mover estos archivos al final (Spacehogs) - Los archivos que coincidan con la máscara serán movidos al área Spacehogs. El programa tiene una lista para todos los archivos más grande de 50 megabytes, archivos a los que no se accedió en el último mes, archivos comprimidos, archivos en la papelera de reciclaje, archivos de service pack, y algunos otros.
  • Archivo de registro - Cuando la casilla de verificación está desmarcada no se creará un archivo de registro con la información sobre la desfragmentación. El archivo de registro se guarda en la carpeta temporal por defecto. Esto puede cambiarse desde el botón seleccionar.
  • Guardar el archivo de registro en la carpeta de la GUI - Esta opción guardará el archivo de registro en la misma carpeta donde JkDefragGUI esté ubicado. Esto desactivará el botón seleccionar


Opciones

Pestañas de la GUI - Opciones

La pestaña de opciones tiene cuatro secciones y un deslizador usado para fijar la transparencia de la GUI.

  • Al iniciar - Todas estas opciones se ejecutarán al inicio de la GUI
  • Dispositivos - Esta sección controla los dispositivos para añadir a la selección de discos en la pestaña general
  • Al salir - Estas opciones se ejecutarán al finalizar y salir de la GUI
  • Varios - Esta sección tiene algunas opciones más

Hay dos botones bajo el dispositivo deslizante, La X roja desactiva la transparencia. El icono de disco se usa para guardar la transparencia al archivo JkDefragGUI.ini


Al iniciar

Opciones – Al iniciar
  • Comprobar actualizaciones al inicio - Cuando JkDefragGUI se inicie hará una conexión a la sección de programas gratis de EMRO Automatisering y comprobará un archivo con información sobre las versiones de la GUI y de JkDefrag. Cuando encuentre una versión actualizada, se ofrecerá para descargar la versión actualizada de la GUI o instalar la versión actualizada de JkDefrag.
  • Restaurar todo por defecto en el siguiente inicio - Cuando esta opción esta seleccionada, en el siguiente inicio de JkDefragGUI serán restaurados por los originales los siguientes archivos: Los archivos de ayuda, idioma, sonido, y los archivos de texto adicionales para que la configuración vuelva a estar con los valores por defecto.
  • Pregunta sobre descargar Pagedefrag otra vez al iniciar - Cuando la GUI inicia por primera vez Pagedefrag no está disponible hasta que se descargue del sitio de Microsoft. Durante el arranque le hará una pregunta por si quiere descargar Pagedefrag. Usted puede seleccionar Sí, No o Cancelar. Seleccionando Sí descargará e instalará las opciones de Pagedefrag en la GUI. Cuando pulse No, no será preguntado de nuevo, si quiere descargar Pagedefrag vea la sección de Preguntas más frecuentes, sobre cómo volver ha hacerlo. Seleccionando Cancelar le preguntará de nuevo en el siguiente inicio del programa.


Dispositivos

Options - Devices
  • Detectar disco extraíble - Los disquetes, memorias USB, IPods, tarjetas de memoria, discos Jazz, discos ZIP.
  • Mostrar disquete (si esta presente) - Cuándo un disquete es introducido en el ordenador y esta opción esta seleccionada, es posible desfragmentar el disquete.
  • Detectar ramdisks - Los RamDisks son unidades virtuales creadas en la memoria o imágenes almacenadas en un disco.


Al salir

Options - On exit
  • Borrar archivo de registro al salir - Cuando selecciona esto, el último archivo de registro es borrado al cerrarla GUI.
  • Apagar después de desfragmentar - Esto causará el apagado del ordenador después de que JkDefrag sea cerrado, aún cuando sea cerrado manualmente. Esta opción no puede guardarse.
  • Guardar configuración al salir - Cuando la GUI se cierra y esta opción esta seleccionada todos los ajustes y todas las opciones serán guardados al archivo de configuración excepto la opción "Apagar después de desfragmentar".


Varios

Opciones - Varios
  • Ocultar el programador de tareas - Cuando esta opción esta activada y hay una tarea programada no será visible en el Panel de control en las Tareas programadas.
  • Cerrar JkDefrag cuando haya finalizado - Esto finalizará automáticamente la pantalla de JkDefrag cuando la desfragmentación haya terminado (parámetro -q).
  • Spacehogs "Espacio sucio" por defecto - En el Spacehogs están los archivos menos importantes que ocupan una buena cantidad de espacio. JkDefrag los mueve detrás de los directorios y los archivos normales, para hacer ha estos más rápidos. Usted puede encontrar la lista interna de spacehogs http://www.kessels.com/JkDefrag en la sección del FAQ. Usted puede añadir más a la lista en la pestaña “Avanzado” (No olvide guardar sus ajustes o marcar "Guardar configuración al salir" para guardarlo automáticamente).
  • Escuchar un sonido al finalizar - Cuando finaliza la desfragmentación se escuchará un sonido, el archivo de sonido puede cambiarse (finished.mp3 en la carpeta de sonidos).
  • Borrar datos en espacio sin uso - Esto hará más difícil restaurar los archivos eliminados
    Ejecutar la opción de limpiado antes de desfragmentar - Esto ejecutará todas las opciones seleccionadas en la pestaña "Limpiador".

JkDefragGUI tiene soporte para CCleaner, cuando CCleaner.exe y ccleaner.ini son copiados en la carpeta de Programas,
la sección Varios tiene otra opción que no está disponible en la situación citada anteriormente. Cuando "Usar CCleaner en su lugar" está seleccionado, estas opciones del Limpiador son reemplazadas por las opciones de CCleaner excepto una cosa, la "Optimización del Registro" solo es ejecutada cuando está seleccionada.


Programador

Pestañas de la GUI - Programador

¿Por qué desfragmentar su ordenador manualmente? Con JkDefragGUI usted puede programar una desfragmentación para ejecutar una sola vez, diariamente, semanalmente, mensualmente o en el arranque. Cuando una tarea está programada con JkDefragGUI para ejecutarse más veces usted puede verlo mediante el texto entre los dos botones sobre el fondo de la pestaña, que estará verde cuando una tarea este programada y será rojo cuando no haya ninguna tarea programada. Cuando su cuenta de usuario no tiene contraseña, puede dejar vacío el campo de contraseña del programador.

Cuando el intervalo "Inicio de sesión" esta seleccionado la opción de retraso estará disponible. Esto programará JkDefrag para ejecutarse tras la entrada en el sistema y esperar una cantidad de segundos antes de empezar. Esto le permitirá al sistema arrancar sin el desfragmentador retrasando el proceso de Inicio.


Instalador

Pestañas de la GUI - Instalador

JkDefragGUI tiene dos instaladores incorporados

  • Instalador de Windows
  • Instalador del Salvapantallas


Instalador - Windows

JkDefragGUI puede instalar a JkDefragGUI en su ordenador. Creará los accesos directos necesarios y colocará JkDefragGUI en la lista de programas de su ordenador. Esto le creará una opción para desinstalar JkDefragGUI como cualquier otro programa. Cuando JkDefragGUI es instalado mediante el instalador incorporado, usted podrá fácilmente actualizar los accesos directos seleccionando o deseleccionando las casillas de verificación y pulsando el botón para que se produzca el cambio (El botón Instalar efectúa los cambios después de instalar).

© Emiel Wieldraaijer 2007/2008

Website : http://www.emro.nl/freeware / Email : emielwieldraaijer@hotmail.com

Revision 1.02


Instalador - Salvapantallas

Jeroen Kessels ha creado una versión de salvapantallas de su programa de desfragmentación que puede ser cómodo... desfragmenta su ordenador automáticamente cuando no está siendo usado. Pero el salvapantallas tiene que copiarse manualmente a la carpeta System32 de su instalación de Windows y después usted tendrá que configurar el salvapantallas. JkDefragGUI simplifica este proceso para usted, seleccione sus opciones y pulse el botón de instalación. Cuándo el salvapantallas este instalado y configurado en su ordenador, usted podrá cambiar fácilmente la configuración desde la GUI o puede quitar el salvapantallas de su ordenador. Otra ventaja de la GUI es la actualización automática del salvapantallas. Cuando JkDefragGUI tiene una versión más nueva del salvapantallas podrá actualizarla automáticamente cuando la GUI se inicia.

  • Intervalo de espera - Marca el tiempo en minutos para que el salvapantallas sea activado.

  • Barra de estado - Selecciona el modo para mostrar la información cuando el salvapantallas de JkDefrag está en actividad.

  • No desfragmentar si la anterior vez fue hace menos de x horas - Este intervalo en horas desactiva el salvapantallas de JkDefrag después de que haya terminado y muestra el salvapantallas alternativo.

  • Alternativo - Selecciona el salvapantallas alternativo que será usado por la anterior selección.

  • Línea de comandos - Fija los comandos que usará el salvapantallas de JkDefrag. Usted los puede poner manualmente o a través de la GUI pulsando el botón de la derecha. El botón rojo con la X borrará la línea de comandos.


Sistema

Pestañas de la GUI - Sistema

La pestaña sistema le permite instalar pagedefrag de Sysinternal. PageDefrag usa técnicas avanzadas para hacer lo que los desfragmentadores comerciales no pueden: La habilidad para desfragmentar su archivo de paginación o memoria virtual y registros. Además de eso, los archivos de registro de eventos de las desfragmentaciones y los archivos de hibernación de Windows 2000/XP (donde la memoria del sistema se guarda cuando usted hiberna una computadora portátil). La versión actual (cuando se escribió esta ayuda es la 2.32) de PageDefrag de Sysinternals que no soporta Windows Vista.

La declaración anteriormente citada sobre Sysinternals no es totalmente cierta. Con un disco BartPE y añadiendo el plug-in de JkDefragGUI que puede descargar desde http://www.emro.nl/freeware. Puede desfragmentar su disco duro desde el exterior de su sistema operativo y los archivos anteriormente citados también serán desfragmentados.

Cuando la GUI se inicia por primera vez, si Pagedefrag no está disponible lo descargará desde el sitio de Microsoft. Durante el arranque le hará una pregunta por si quiere descarga Pagedefrag. Usted puede seleccionar Sí, No o puede Cancelar. Seleccionando Sí hará una descargar e instalará las opciones de Pagedefrag en la GUI. Cuando pulse No, no será preguntado de nuevo, si posteriormente quiere descargar Pagedefrag vea la sección de Preguntas más frecuentes, sobre cómo volver ha hacerlo. Seleccionando Cancelar le preguntará de nuevo en el siguiente inicio del programa.


Limpiador

Pestañas de la GUI - Limpiador

JkDefragGUI puede hacer una limpieza básica de su perfil de usuario o puede limpiar los perfiles de todos los usuarios marcando todas las carpetas que quiera, pero tendrá que tener permisos sobre todas las carpetas de los perfiles.

La carpeta Prefetch es usada por Windows XP para acelerar el proceso de Inicio. Windows XP registra nformación acerca de cada programa que ejecuta en el arranque y usa esa información para iniciarlo más rápido la próxima vez. Puesto que múltiples archivos podrían tener el mismo nombre, añade un "hash" de la posición del archivo. Esa es la extraña cadena de números y letras entre el nombre de archivo y la extensión .pf. Esta carpeta puede acumular asura inservible, especialmente si usted cambia mucho su configuración. No hay perjuicio en vaciarla. Windows la reconstruirá según se necesite

La optimización del Registro llama a un programa externo NTREGOPT. La optimización hecha por NTREGOPT simplemente compacta las celdas del registro para minimizar su tamaño.

Todos estas opciones excepto la "Optimización del Registro" las puede sobrescribir con una opción de la pestaña de opciones
"Usar CCleaner en su lugar" estas opciones están sólo disponibles cuando CCleaner.exe y ccleaner.ini son copiados manualmente en
la carpeta de programas. Las versiones anteriores de CCleaner usaban winapp.ini en lugar de ccleaner.ini.


Borrar espacio libre

Pestañas de la GUI - Borrar espacio libre

JkDefragGUI también puede borrar datos de su disco que usted pensaba que ya no existían.
Algunas herramientas de recuperación de disco pueden recuperar los archivos que han sido borrados desde
Windows, aún cuando los archivos del disco hallan sido formateados pueden ser recuperados. La función
"Borrar espacio libre" llena su disco con datos aleatorios y esto hará mucho más difícil recuperar esos
archivos. Si usted repite el procedimiento varias veces hará imposible recuperar esos archivos.
Esto aumentará su privacidad.


Menu
  • Archivo
  • Ver
  • Idioma
  • Configuración
  • ?


Archivo

Menú - Archivo

  • Ejecutar desfragmentador - Esto iniciará JkDefrag con las opciones que usted haya seleccionado enla GUI
  • Leer registro - Lea el registro de eventos creado por JkDefrag desde adentro de la GUI
  • Salir - Sale de JkDefragGUI


Ver

Menú - Ver
  • Mostrar instalador - Cuando selecciona la pestaña del instalador se hace visible de otra forma no será visible.
  • Mostrar programador - Cuando selecciona la pestaña del programador se hace visible de otra forma no será visible.
  • Mostrar sistema - Cuando selecciona la pestaña del sistema se hace visible de otra forma no será visible.
  • Mostrar limpiador - Cuando selecciona la pestaña del limpiador se hace visible de otra forma no será visible.
  • Mostrar borrado del espacio libre - Cuando está seleccionada, esta pestaña es visible de otra forma estará oculta

El menú Ver no se muestra en el modo BartPE


Idioma

Menú - Idioma

JkDefragGUI soporta varios idiomas que usted puede seleccionar en el menú de idioma. El idioma seleccionado es guardado en JkDefragGUI.ini. Se utilizan las siguientes abreviaturas.

Idioma | Abreviatura
Portugués Brasileño | BRP
Búlgaro | BU
Catalán | CA
Chino Simplificado | ZH2
Chino Tradicional | ZH1
Checo | CZ
Holandés | NL
Indonesia | INA
Inglés | EN
Francés | FR
Alemán | DE
Griego / Heleno | GR
Húngaro | HU
Italiano | IT
Japonés | JP
Polaco | PL
Portugués | PT
Rumano | RO
Ruso | RU
Serbio | SR
Esloveno | SL
Eslovaco | SK
Español | ES
Sueco | SE
Valenciano | VA
Croata | HR
Hebreo | HE
Turco | TR
Ucraniano | UA


Configuracion

Menú - Configuración
  • Guardar configuración - Guardará todas las opciones que ha seleccionado enla GUI
  • Restaurar configuración - Esto restaurará todas las opciones a las que venían por defecto en la GUI
  • Copiar configuración al portapapeles - Copia todas las opciones seleccionados de JkDefrag al portapapeles


?

Menú - Ayuda
  • Sitio web de Jeroen Kessels
  • Sitio web de EMRO Automatisering
  • Sitio web de Sysinternals
  • Sitio web de Lars Hederer
  • Ayuda – Este archivo de ayuda
  • Créditos - Dándole las gracias a todas las personas que me ayudan con la traducción o desarrollo de JkDefragGUI
  • Leer el historial de cambios - Lea los cambios de cada versión de JkDefragGUI
  • Leer el historial de cambios (JkDefrag) - Lea los cambios de cada versión de JkDefrag
  • Colores de JkDefrag - Explicación de los colores usados por JkDefrag.
  • Comprobar en busca de actualizaciones - Comprueba manualmente las actualizaciones de JkDefragGUI y JkDefrag.


Bandeja de sistema

El icono de la bandeja del sistema de JkDefragGUI tiene seis opciones

  • Reiniciar transparencia - Restaura la transparencia escogida
  • Detener JkDefrag.exe - Detiene la versión que este en ejecución de JkDefrag.exe
  • Colores de JkDefrag - Muestra los colores usados por JkDefrag
  • Ejecutar - Inicia JkDefrag con las opciones que usted tenga seleccionadas enla GUI
  • Salir - Sale de JkDefragGUI, pero esto no detendrá inmediatamente al JkDefrag.exe que se este ejecutando
  • Iniciar el borrado - Borra los datos sensibles del espacio libre de su disco


Teclas de acceso rapido

Teclas de acceso rápido

Tecla | Descripción corta | Descripción larga
F1 | Ayuda | Muestra este archivo de ayuda
F3 | Guardar configuración | Guarda todas las opciones seleccionadas a un archivo de configuración
F4 | Copiar la configuración al portapapeles | Copia todas las opciones seleccionadas de JkDefrag al portapapeles
F5 | Ejecutar desfragmentación | Esto ejecuta JkDefrag con las opciones configuradas en la GUI
F6 | Leer archivo de registro | Abre el último archivo de registro
F7 | Guardar archivo de registro | Esto le mostrará una ventana para guardar el archivo de registro en otro lugar
F8 | Imprimir archivo de registro | Esto le mostrará automáticamente una pantalla con las impresoras instaladas y le permitirá imprimir el archivo de registro
F9 | Borrar espacio libre | Borra los datos sensibles del espacio libre del disco seleccionado
F10 | Salir | Finaliza JkDefragGUI
F12 | Comprobar actualizaciones | Revisa manualmente si hay una actualización de JkDefragGUI o JkDefrag


Linea de comandos

Línea de comandos

JkDefragGUI puede ser ejecutado con cuatro parámetros

/h y /hs, son dos parámetros que inician JkDefrag con las opciones guardadas porla GUI y ejecuta JkDefrag sin ser mostrado al usuario. La diferencia entre /h y /hs es que /hs puede apagar el ordenador cuando la desfragmentación ha finalizado o el proceso finaliza. El modo oculto está sólo disponible con estos parámetros.

/s this will autoselect "shutdown after defrag" in the GUI

/r this will automaticly run JkDefrag with saved options including cleaning and wash function.

/rs same as /r but will shutdown the computer when completed.

/d:x: selects drive X: as default drive in the GUI

/c:file checks for a configurationfile called file in the config folder, this will overwrite the settings saved in JkDefragGUI.ini

/reset, puede restaurar casi todo por defecto, archivos de ayuda, archivos de idioma, imágenes, sonido y la configuración, así como también puede hacerse seleccionando una opción en la sección "Al iniciar" de la pestaña “Opciones”.

Y por último /? mostrará la ayuda de la línea de comandos como el siguiente cuadro.

La línea de comandos no soporta la función de limpiado.

La línea de comandos no soporta la función de limpiado.


Programas externos

  • JkDefrag
  • JT
  • Pagedefrag
  • NTREGOPT
  • CCleaner


JkDefrag

Programas externos - JkDefrag

JkDefrag from Jeroen Kessels

Desfragmentador y optimizador de discos, gratis y libre (liberado bajo la Licencia Pública General de GNU) utilidad para Windows 2000/2003/XP/Vista/X64. Completamente automático y muy fácil de usar, rápido, de bajo consumo, con varias estrategias de optimización, puede manejar disquetes y discos USB. Incluido con una versión para Windows, una versión de línea de comandos (para programar por el Administrador de tarea o para el uso del administrador mediante un scripts), una versión de salvapantallas, una librería DLL (para usar con otros lenguajes de programación), y versiones para Windows X64.

JkDefrag es un desfragmentador de discos que se ejecuta según se necesita o en modo automático por medio de los parámetros de línea de comando o integrado al salvapantallas. Por defecto, el programa usa una "Optimización rápida", diseñada para todos los días, pero también soporta parámetros personalizados que pueden mover los archivos hasta el final (o el principio) del disco, los puede ordenar por nombre, tamaño y otros criterios. Si bien JkDefrag puede ser administrado con una GUI estándar de Windows, la mayor parte de esas poderosas características son dirigidas a usuarios que están familiarizados con el uso de la línea de comandos. JkDefragGUI fue creado para personas que no tienen las habilidades de un usuario avanzado y que quieren poder utilizar estas poderosas características o para esas personas que les gusta una GUI en lugar de una línea de comandos.

JkDefrag no contiene ningún programa adware o spyware.

Para más información visite el sitio web de Jeroen Kessels: http://www.kessels.com


JT (Task Scheduler)

Programas externos - JT

JkDefragGUI tiene la capacidad de programar desfragmentaciones. JkDefragGUI usa un programa externo. Microsoft ® Task Scheduler Command Line Utility "JT.exe" es un conjunto de utilidades de Windows 2000. JT.exe es compatible con NT/2000/2003/XP/Vista.

Usted puede descargar JT.exe desde ftp://ftp.microsoft.com/reskit.


Pagedefrag

Programas externos - Pagedefrag

Una de las limitaciones de la interfaz de desfragmentación de Windows NT/2000 es que no es posible desfragmentar archivos que son abiertos para un acceso exclusivo. Así, los programas estándar de desfragmentación no le pueden mostrar como de fragmentados o desfragmentados esta sus archivos de paginación o archivos de Registro. La fragmentación del archivo de paginación y Registro pueden ser una de las causas principales de la degradación del funcionamiento de un sistema.

PageDefrag usa técnicas avanzadas qué desfragmentadores comerciales no tienen: La habilidad de ver como de fragmentados esta sus archivos de paginación y de Registro, y para desfragmentarlos. Además, los archivos de registro de eventos de desfragmentado y los archivos de hibernación de Windows 2000/XP (donde la memoria del sistema se guarda cuando usted hiberna una computadora portátil).

PageDefrag trabaja con Windows NT 4.0, Windows 2000, Windows XP, y Server 2003.

Para más información visite el sitio web: http://www.microsoft.com/technet/sysinternals/default.mspx


NTREGOPT

Programas externos - NTREGOPT

JkDefragGUI incluye otra herramienta fantástica que se llama NTREGOPT. Es una pequeña herramienta de Optimización del Registro que esta diseñada para Windows NT/2000/2003/XP. El programa esta echo por Lars Hederer y la versión incluida es la 1.1j del 10/20/2005. Para otros buenos programas de Lars Hederen visite su sitio web: http://www.larshederer.homepage.t-online.de

Introducción

Similar al Windows 9x/Me, el archivo de registro en un sistema basado en NT puede fragmentarse con el paso del tiempo, ocupando más espacio en su disco duro de lo que es realmente necesario y decreciendo el rendimiento del sistema. Usted debería usar la utilidad NTREGOPT regularmente, pero especialmente después de instalar o desinstalar un programa, minimiza el tamaño de los archivos del registro y optimiza el acceso al registro. El programa trabaja recreando cada celda del registro "desde cero", así quita cualquier espacio vacío que puede quedar de claves previamente modificadas o borradas. Tenga en cuenta que el programa no modifica el contenido del registro de ningún modo, ni desfragmenta físicamente los archivos del registro en el disco (como lo hace el programa PageDefrag de SysInternals). La optimización hecha por NTREGOPT simplemente compacta las celdas del registro para minimizar lo más posible su tamaño.

Sistemas operativos soportados

Windows NT 3.51- Windows NT 4.0- Windows 2000- Windows 2003- Windows XP- y probablemente más, todas las versiones futuras de Windows basadas en la instalación del kernel de NT

Parámetros de la línea de comandos de NTREGOPT

NTREGOPT soporta parámetros de la línea de comandos con los que usted puede realizar una optimización "silenciosa" del registro, sin interacción del usuario.

La sintaxis para la línea de comandos de NTREGOPT es:

NTREGOPT silent [/noprogresswindow] [/reboot] (Los parámetros entre corchetes son opcionales.)

Descripción de los parámetros de la línea de comandos:

  • silent, pone NTREGOPT en el modo "silencioso" y permite los otros parámetros\
  • /noprogresswindow, oculta la ventana de progreso durante la optimización.
  • /reboot, automáticamente reinicia el ordenador cuando la optimización del registro es completada.

Problemas conocidos

NTREGOPT algunas veces falla con error 1450 - "No existen recursos suficientes en el sistema para completar el servicio pedido" - al intentar guardar una celda optimizada del registro. Yo aún no he podido reproducir este error en ningún ordenador personal, y los informes de usuarios afectados señalan que algunas veces también falla al intentar hacer una copia de seguridad de una celda crítica usando el programa REGBACK de Microsoft. Esto hace imposible que yo pueda hacer nada por evitarlo (el programador). Algunos usuarios reportaron sin embargo que pudieron evitar el problema ejecutando NTREGOPT en el modo seguro de Windows, y en un caso desinstalando una suite del software Symantec solucionado el problema permanentemente. Un usuario reportó que incrementando el valor "IRPStackSize" como esta descrito en artículo Microsoft Knowledge Base 177078 corrigió el problema en su sistema. Cuando el sistema es reiniciado después de una optimización con NTREGOPT, Windows Server 2003 por defecto mostrará el rastreador de eventos de apagado durante la entrada en el sistema preguntando por qué el sistema ha sido apagado inesperadamente. Ésto es porque la información del apagado fue escrita en la copia "vieja" del registro durante el apagado del sistema fue reemplazado por la copia del registro optimizada después el sistema fue reiniciado, y por eso la información del apagado es descartada y el rastreador de eventos de apagado piensa que el sistema falló. Usted puede querer desactivar al rastreador para evitar este mensaje en el futuro (vea la ayuda de Windows para mayor información sobre cómo hacer esto). Si usted experimenta algún otro problema, por favor envíeme un email con una descripción detallada y yo veré si le puedo ayudar.

Localización

Usted puede traducir este programa a su idioma editando el archivo NTREGOPT.LOC. Tenga en cuenta que el archivo debería ser editado utilizando un editor basado en Windows (el Bloc de Notas), para asegurarse que cualquier carácter OEM es mostrado correctamente en el programa. Si su idioma no está aún presente en mi página web y usted quiere que su idioma esté disponible para el público general, es bienvenido a enviarme su traducción. Entonces lo pondré disponible para su descarga, con créditos por supuesto. He incluido un archivo del idioma alemán. Si ustedes quieren usar el programa en alemán, simplemente descomprima el archivo LOC_GER.ZIP en su carpeta de NTREGOPT.

Historial de versiones

NTREGOPT v1.1j - 10/20/2005

- Fixed compatibility issues with 64-bit Windows (many thanks to Ian Smith and Hajo for all testing)

- Enhanced error messages

NTREGOPT v1.1i, - 08/17/2005

- Optimization results are now calculated correctly when optimization failed on one or more hives

NTREGOPT v1.1h - 03/06/2005

- Updated homepage address

NTREGOPT v1.1f - 08/26/2004

- Window position is now screen center instead of desktop center, fixing display problem when using multiple monitors (thanks John :)

NTREGOPT v1.1e - 07/31/2004

- Optimization results: use thousand separator

NTREGOPT v1.1d - 07/07/2004

- Optimized error handling

NTREGOPT v1.1c - 05/10/2004

- Fixed problems with dynamic disks

- Re-added support for Windows NT 3.51 (got lost with v1.1)

NTREGOPT v1.1b - 04/23/2004

- NTREGOPT is now compatible with Windows Server 2003 and Windows XP Service Pack 2

- Fixed a problem where the registry hives could not be optimized on some systems

NTREGOPT v1.1a - 10/03/2002

- Fixed a problem where the registry hives could not be optimized on some systems

NTREGOPT v1.1, 09/25/2002

- Added command line support- Show optimization results (initial and new registry size)

NTREGOPT v1.0 - 11/24/2001

- Initial release

Distribución

El programa NTREGOPT es gratis. Por favor páseselo a cualquiera que usted piense que le puede resultar útil. Yo explícitamente permito que este programa sea incluido en cualquier archivo comprimido, CD-ROM u otro medio, así como también colección de programas con tal que todos los archivos no sean modificados y permanezcan inalterados. Una nota rápida por email donde mi programa haya sido incluido es de agradecer.

Donaciones

Aunque elegí hacer mi programa gratis a fin de que nadie esté obligado a pagar por usarl, acepto y aprecio las donaciones. Entonces, si ustedes encuentran mis programas útiles y quiere dar soporte a más desarrollos, simplemente visite mi página web y dé un clic sobre el botón "PayPal", o done directamente a mi dirección de correo electrónico por medio de PayPal. ¡Gracias anticipadas! Si usted vive en Alemania y quiere hacer una donación, también puede transferir dinero directamente a mi cuenta corriente. Contácteme para más información.

Descarga de responsabilidades

Use this software at your own risk. I do not take responsibility for anything that might happen to you or the PC upon use of my program, including but not limited to: registry destruction, hard disk crash, heart attack...

Español

Use este software bajo su responsabilidad. No me hago responsable de ninguna cosa que le pueda ocurrir a usted o a su ordenador personal con el uso de mi programa, incluyendo pero no limitándose a: destrucción del registro, del disco duro, ataque al corazón...

Comentarios y sugerencias por email, ¡sin embargo, son siempre bienvenidos!


CCleaner

Programas externos - CCleaner

JkDefragGUI tiene un limpiador pero es uno muy simple. Hay uno más avanzado disponible en Internet y su nombre es CCleaner. CCleaner es un producto de Piriform y tiene más de una cosa en común con JkDefrag. Permite a Windows funcionar más rápido, más eficazmente. Es un programa pequeño, gratis y no contiene adware.

Resumen del Programa:

Limpia los siguientes componentes de Windows y muchos más :

  • Internet Explorer
    - Archivos temporales de Internet
    - Historial
    - Cookies
    - Borrar archivos Index.dat
    - Ubicación de últimas descargar
  • Firefox
    - Archivos temporales de Internet
    - Historial
    - Cookies
    - Historial de descargas
  • Opera
    - Archivos temporales de Internet
    - Historial
    - Cookies
  • Vaciar Papelera
  • Portapapeles
  • Achivos temporales de Windows
  • Achivos de registro de Windows
  • Documentos recientes (en el menú Inicio)
  • Ejecuciones (en el menú Inicio)
  • Historial del asistente de búsqueda de Windows
  • Datos antiguos de Prefetch
  • Descargas de memoria de Windows
  • Fragmentos de archivos de Chkdsk

Las opciones avanzadas permiten la limpieza de:

  • Cache de disposición de menú
  • Cache de notificación de Bandeja
  • Cache de tamaño/ubicación de ventanas
  • Historial de asistencia al usuario
  • Achivos de registro de IIS
  • Personalizar archivos y carpetas

Limpieza por aplicaciones:

Así como limpia viejos archivos y antiguas configuraciones de componentes de Windows, CCleaner también limpia archivos temporales y listas de archivos recientes para muchas aplicaciones. Inclusive:

  • Firefox, Opera, Safari, Media Player, eMule, Kazaa, Google Toolbar, Netscape, Microsoft Office, Nero, Adobe Acrobat Reader, WinRAR, WinAce, WinZip y más ...

Limpieza del Registro:

CCleaner utiliza una limpieza avanzada del Registro para revisar en busca de problemas e inconsistencias. Puede comprobar los siguientes:

  • Extensiones de archivo inválidas
  • Controles ActiveX
  • Controles ClassIDs
  • ProgIDs
  • Desinstaladores
  • DLLs compartidas faltantes
  • Fuentes
  • Help File references
  • Rutas de aplicación
  • Iconos
  • Accesos directo inválidos y más...

Seguridad:

CCleaner was designed from the ground to be safe and secure to use. It has multiple levels of checks in place to ensure that it cannot delete any useful information or documents you may still need. We also certify that it contains no Spyware or Adware.

Seguridad alta:

For the super cautious users we also offer secure file erasing. By overwriting the files before deleting them, making it impossible to recover the data.

Multiples idiomas:

Gracias a los traductores, CCleaner está disponible en 35 idiomas diferentes

English, Albanian, Arabic, Bosnian, Bulgarian, Catalan, Chinese (Simplified), Chinese (Traditional), Czech/Slovak, Danish, Dutch, Finnish, French, Galician, German, Greek, Hebrew, Hungarian, Italian, Japanese, Korean, Lithuanian, Macedonian, Norwegian, Polish, Portuguese, Portuguese (Brazilian), Romanian, Russian, Serbian Cyrillic, Serbian Latin, Slovak, Spanish, Swedish and Turkish.

Para más información visite su sitio web : http://www.ccleaner.com


Servicio y Soporte

Servicio y Soporte - JkDefragGUI por defecto
  • Preguntas más frecuentes (FAQ)
  • JkDefragGUI por defecto
  • Estructura de carpetas


Preguntas mas frecuentes (FAQ)

Servicio y Soporte – Preguntas más frecuentes (FAQ)

Preguntas
  1. Mi idioma no está disponible en la GUI, ¿puedo añadir el mío?
  2. Puedo programar una tarea remotamente con JkDefragGUI ?
  3. Mis archivos de idioma estan dañados, ¿que puedo hacer?
  4. Utilizo el programador de tareas incorporado pero cuando vuelvo a arrancar JkDefragGUI los ajustes se han restablecido, ¿que esta mal?
  5. ¿Como puedo usar CCleaner en lugar del limpiador incorporado?
  6. Cuando JkDefrag está ejecutandose, JkDefragGUI se ejecuta en segundo plano. ¿Se puede salir de JkDefragGUI ?
  7. ¿Me puede dar usted algún otro consejo?
  8. Encontré un fallo, ¿que puedo hacer?
  9. Después de usar la función de borrado no quedan datos en el espacio libre del disco, ¿Qué puede ocurrir?
  10. ¿Puedo quitar los archivos de ayuda que no uso?
  11. Pagedefrag no esta disponible en la GUI ¿qué ha pasado?

1. ¿Mi idioma no está disponible en la GUI, ¿ puedo añadir el mío?

Usted puede, editar el archivo user.lng de la carpeta de "languages". Lo más importante es cambiar el "&User" que activará el idioma creado por el usuario este texto se mostrará en el menú de idiomas. No cambie los valores entre [ ] sólo el cambie el texto después de ellos. Si usted los quiere compartir el idioma con el resto de mundo y estaría dispuestos a mantener el archivo de lenguaje, por favor ser se tan amable de enviarme una copia de su idioma. Usted lo puede enviar por correo electrónico a emielwieldraaijer@hotmail.com

Volver arriba

2. ¿Puedo programar una tarea remotamente con JkDefragGUI?

No, JkDefragGUI no soporta programación remota en otro ordenador tal vez esta característica se agregará en un futuro.

Volver arriba

3. Mis archivos de idioma están dañados, ¿que puedo hacer?

Salga de JkDefragGUI y borre todos los archivos de la carpeta "languages", vuelva a arrancar el programa.

Volver arriba

4. Utilizo el programador de tareas incorporado pero cuando vuelvo a arrancar JkDefragGUI los ajustes se han restablecido, ¿ que esta mal?

Los ajustes en la pestaña del Administrador se usan sólo para programar la desfragmentación. No muestra las opciones de las tareas programadas. Si usted quiere cambiar los ajustes tendrá que guardar la configuración. Usted puede guardar la configuración pulsando la tecla F3 o en el menú "Configuración" pulsado "Guardar configuración"

Volver arriba

5. ¿Cómo puedo usar CCleaner en lugar del limpiador incorporado?

Instale CCleaner en su ordenador y copie los archivos ccleaner.exe, ccleaner.ini y winapp.ini a la carpeta "programs" donde esté instalada la GUI. Una opción adicional se mostrará en la pestaña "Opciones" sección "Varios", llamada "Usar CCleaner en su lugar". CCleaner será usado, cuando este marcada esa casilla de verificación.

Volver arriba

6. Cuando JkDefrag está ejecutándose, JkDefragGUI se ejecuta en segundo plano. ¿Se puede salir de JkDefragGUI?

Usted puede salir de JkDefragGUI mientras JkDefrag se ejecuta, clic derecho sobre el icono de JkDefragGUI en la bandeja del sistema y seleccione salir (Clic izquierdo puede configurarse para hacer lo contrario).

Volver arriba

7. ¿Me puede dar usted algún otro consejo?

  1. Limpie todos archivos viejos de su disco duro antes de ejecutar JkDefrag
  2. Reinicie antes de ejecutar JkDefrag. Esto liberará archivos que están en uso, así se podrán desfragmentar.
  3. Detenga su escáner del antivirus en tiempo real antes de ejecutar JkDefrag. Los escáneres del antivirus comprueban toda la actividad del disco, y la desfragmentación y optimización se hará muy lenta.
  4. Mueva el swapfile a otro volumen o partición, reinicie, desfragmente, y vuelva a poner el swapfile donde estaba. Si usted no tiene un segundo volumen o partición, entonces reduzca de tamaño el swapfile, a 100MB por ejemplo.
  5. Si una aplicación (por ejemplo una base de datos) impide desfragmentar ciertos archivos entonces detenga JkDefrag, y ejecútelo solo para el directorio particular de esos datos, y vuelva a arrancar la aplicación.
  6. Haga un disco BartPE y utilice el Plugin BartPE, cuándo ejecuta JkDefragGUI en un ambiente BartPE todos los archivos pueden ser desfragmentados.

Volver arriba

8. Encontré a un fallo, ¿que puedo hacer?

Envíe un email a emielwieldraaijer@hotmail.com, ponga tanta información como le sea posible, Sistema operativo, Idioma, Memoria y toda la otra información. Si se le muestra un mensaje de error por favor adjúntelo al correo electrónico. Para los que no saben cómo copiar el mensaje: Pulse la tecla <Alt> y <ImpPant> sujetando las dos teclas al mismo tiempo, inicie el programa Pain que se encuentra en el menú Inicio - accesorios y <ctrl> y <v> al mismo tiempo. Guarde la imagen y adjúntela al correo electrónico. Para obtener información de su sistema, también podría descargar el programa SimpleSysInfo y puede escoger el botón de información del sistema, para guardar el archivo de texto con toda la información de su ordenador y adjuntarlo también al correo electrónico (Por favor quite la línea con su información del número de serie de su sistema).

Volver arriba

9. Después de usar la función de borrado no quedan datos en el espacio libre del disco, ¿Qué puede ocurrir?

La función de borrado llena el disco de datos aleatorios y cuando no hay mas espacio libre la basura será eliminada. Algunas veces el archivo de basura que se guarda en la raíz del disco no puede ser eliminado. El archivo se llama JkDefragGUI Eraser.tmp y puede borrarse del disco sin ningún problema. Este problema puede deberse a los escáneres de los antivirus y los recursos del sistema.

Volver arriba

10. ¿Puedo quitar los archivos de ayuda que no uso?

Usted puede borrar los archivos en la carpeta de ayuda, exceptuando JkDefragGUI.chm. Si quiere quitar JkDefragGUI.chm debe renombrar otro archivo de ayuda como JkDefragGUI.chm. Cuando no se encuentra ningún archivo de ayuda de un idioma en particular se usa el inglés.

Volver arriba

11. Pagedefrag no esta disponible en la GUI ¿qué ha pasado?

Cuando JkDefragGUI se inicia por primera vez se le hace una pregunta sobre descargar Pagedefrag. Si seleccionó No Pagedefrag no será descargado y no será preguntado de nuevo. Para resolver este problema seleccione en la GUI "Restaurar todo por defecto en el siguiente inicio" en la pestaña Opciones, Botón Sobre el Arranque y seleccione "Preguntar para descargar Pagedefrag otra vez al iniciar" o puede editar JkDefragGUI.ini cambiando PageDefragDownload=NO a PageDefragDownload=YES.

Volver arriba


JkDefragGUI por defecto

Servicio y Soporte - JkDefragGUI por defecto

General por defecto
Idiomas |  | Por defecto el idioma cuando se inicia por la primera vez se basa en el idioma del Sistema operativo, sino será inglés.
Pestaña General
 | Acción | 3 - Analizar, desfragmentar y optimización rápida
 | Nivél de depuración | 1 – Mensaje de aviso
 | Unidad | C:
 | Todos los discos (casilla) | No marcada
 | Velocidad | 100 %
 | Espacio libre | 1 %
Pestaña Avanzado
 | Incluir | Nada puesto
 | Excluir | Nada puesto
 | Mover estos archivos al final. (Spacehogs) | Nada puesto
 | Usar achivo de registro | Marcado
 | Guardar el archivo de registro en la carpeta de la GUI | No marcado
 | Localización del archivo de registro | Carpeta temp del usuario actual
Pestaña Programador
 | Nombre de usuario | Usuario acutal
 | Contrasela | No visible pero es NULA, cuando el usuario actual no tiene ninguna contraseña especificada
 | Hora | 23:59
 | Fecha | Fecha actual
 | Intervalo | Semana
 | Detener | 0
 | Día | Lunes (LU)
Instalador - Windows
 | Añadir GUI al inicio de Windows | No marcado
 | Crear acceso directo en el Escritorio | Marcado
 | Crear carpeta en el menú Inicio | Marcado
 | Crear acceso directo en el inicio rápido | Marcado
 | Instalar JkDefragGUI en | Archivos de programa \JkDefragGUI
Instalador - Salvapantallas
 | Intervalo de espera | 10 minutos
 | Barra de estado | Barra de estado completa
 | No desfragmentar si la anterior vez fue hace menos de X horas | 4
 | Alternativo | Nada puesto
 | Línea de comandos | Nada puesto
Sistema
 | En el siguiente reinicio | No seleccionado
 | Cada reinicio | No seleccionado
 | Cuenta atrás para abortar la desfragmentación | 3 (Agrisado)
 | No desfragmentar (desinstalar) | Seleccionado
Limpiador
 | Usuario actual | Nada marcado
 | Todos los usuarios | Nada marcado
 | Vaciar la carpeta temp de Windows | No marcado
 | Vaciar la carpeta prefetch | No marcado
 | Optimización de Registro | No marcado
 | Vaciar la Papelera en todos los discos duros | No marcado
Borrar espacio libre
 | Repetir X veces | 1
 | Seleccionar todos los discos fijos | No marcado
Opciones – Al iniciar
 | Comprobar actualizaciones al inicio | No marcado
 | Restaurar todo por defecto en el siguiente inicio | No marcado
Opciones - Dispositivos
 | Detectar disco extraible | No marcado
 | Mostrar disquete (si esta presente) | No marcado
 | Detectar ram disks | No marcado
Opciones – Al salir
 | Borrar archivo de registro al salir | No marcado
 | Apagar después de desfragmentar | No marcado
 | Guardar configuración al salir | No marcado
Opciones - Varios
 | Ocultar programador de tareas | No marcado
 | Cerrar JkDefrag cuando haya finalizado | No marcado
 | Spacehogs “Espacio sucio” por defecto (Archivos > 50MB) | Marcado
 | Escuchar un sonido al finalizar | No marcado
 | Borrar datos del espacio de disco no usado | No marcado
 | Ejecutar la opción de limpiado antes de desfragmentar | No marcado
 | Usar CCleaner en su lugar (Vea instrucciones ) | No marcado


Estructura de carpetas

Servicio y Soporte – Estructura de carpetas

Archivos y Directorios |  | Descripción
(Los archivos de más alto nivel)
JkDefragGUI.exe |  | El programa principal
JkDefragGUI.ini |  | El archivo de configuración usado por JkDefragGUI.exe
Changelog.txt |  | Vea el capítuki Información de version de JkDefragGUI
Readmefirst.txt |  | Archivo importante que debería leer antes de usar JkDefragGUI
Uninstall.exe |  | El desinstalador JkDefragGUI (solo disponible si JkDefragGUI esta insatalado)
Help (Ayuda)
 | JkDefragGUI.chm | Archivo de ayuda en Inglés
 | JkDefragGUI_ES.chm | Este archivo de ayuda
 | JkDefragGUI_NL.chm | Archivo de ayuda en Holandés
 | JkDefragGUI_VA.chm | Archivo de ayuda en Valenciano
Languages (Idiomas)
 | brazilianportuguese.lng | Brazilian Portuguese translation of JkDefragGUI
 | bulgarian.lng | Bulgarian translation of JkDefragGUI
 | catalan.lng | Catalan translation of JkDefragGUI
 | croatian.lng | Croatian translation of JkDefragGUI
 | ukrainian.lng | Ukrainian translation of JkDefragGUI
 | czech.lng | Czech translation of JkDefragGUI
 | dutch.lng | Dutch translation of JkDefragGUI
 | english.lng | English translation of JkDefragGUI
 | france.lng | France translation of JkDefragGUI
 | german.lng | German translation of JkDefragGUI
 | hebrew.lng | Hebrew translation of JkDefragGUI
 | hellenic.lng | Greek/Hellenic translation of JkDefragGUI
 | hungarian.lng | Hungarian translation of JkDefragGUI
 | indonesian.lng | Indonesian translation of JkDefragGUI
 | italian.lng | Italian translation of JkDefragGUI
 | japanese.lng | Japanese translation of JkDefragGUI
 | polish.lng | Polish translation of JkDefragGUI
 | portuguese.lng | Portuguese translation of JkDefragGUI
 | romanian.lng | Romanian translation of JkDefragGUI
 | russian.lng | Russian translation of JkDefragGUI
 | serbian.lng | Serbian translation of JkDefragGUI
 | simplifiedchinese.lng | Simplified Chinese translation of JkDefragGUI
 | slovak.lng | Slovak translation of JkDefragGUI
 | slovenian.lng | Slovenian translation of JkDefragGUI
 | spain.lng | Traducción al Español de JkDefragGUI
 | swedish.lng | Swedish translation of JkDefragGUI
 | traditionalchinese.lng | Traditional Chinese translation of JkDefragGUI
 | turkish.lng | Turkish translation of JkDefragGUI
 | ukrainian.lng | Urkainian translation of JkDefragGUI
 | user.lng | Traducción definida por del usuario de JkDefragGUI
 | valencian.lng | Valencian translation of JkDefragGUI
Programs (Programas)
 | 7za.exe | La versión de línea de comandos de 7-Zip usado para extraer los archivos al descargarlos en el primer arranque y para las actualizaciones
 | 7za-readme.txt | El acuerdo de licencia de 7za
 | jkdefrag.exe | El programa de desfragmentación principal usado por esta GUI
 | jkdefrag64.exe | La versión de 64bits de JkDefrag.exe
 | jkdefragcmd.exe | La versión de línea de comandos de JkDefrag que es usada por el administrador de tareas y para el modo oculto
 | jkdefragcmd64.exe | La versión de 64bits de JkDefragcmd.exe
 | jkdefragscreensaver.scr | El salvapantallas
 | jkdefragscreensaver64.scr | La versión de 64bits de jkdefragscreensaver.scr
 | jkdefragscreensaver.exe | El ejecutable del salvapantallas
 | jkdefragscreensaver64.exe | La versión de 64bits de jkdefragscreensaver.exe
 | jt.exe | La herramienta de planificación en línea de comandos de Microsoft Windows 2000
 | ntregopt.exe | El Optimizador del Registro de Lars Hederer
 | ntregopt.loc | El archivo de idiomausado por ntregopt.exe
 | ntregopt.txt | Eula y documentación de ntregopt.exe
 | pagedfrg.exe | PageDefrag de Sysinternals
 | pagedfrg.hlp | Archivo de ayuda de PageDefrag
 | pagedfrg_eula.txt | EULA de sysinternals relativo a PageDefrag
 | timeout.exe | El programa timeout.exe es para añadirle un intervalo de espera a un archivo batch
Sounds (Sonidos)
 | finished.mp3 | Este sonido será escuchado dolo cuando JkDefrag ha terminado la desfragmentación (sólo cuando este activó)


Informacion de Version (Change log)

Información de Version

JkDefragGUI 1.03 - October 12th 2008

- Added JkDefrag.exe and other files to the archive, request of Jeroen Kessels
- Added a question to download JkDefrag when it isn't found in the program folder
- Added check to see if CCleaner is installed on local computer and update JkDefragGUI with it
- Added Ukrainian translation

- Added Turkish translation

- Added multiple logfiles support
- Added -s to commandline this will autoselect shutdown after defrag in the GUI
- Added -r to commandline this will automaticly run JkDefrag with saved options
- Added -rs to commandline this will automaticly run JkDefrag with saved options and shutdown afterwards

- Added read settings from scheduled job (only new onces)
- Changed JkDefragGUI Icon and TimeOut Icon

- Changed location of logfile when saved in the same folder as the GUI for U3 Devices to U3 documents folder

- Embedded background image into the executable

- Fixed bug Installer not working 100% when JkDefragGUI.exe is renamed

- Improved internal cleaner reading settings from all existing profiles
- Improved support CCleaner, internal cleaner can control CCleaner settings
- Improved deleting folders IECache and History current user, will not leave empty folders anymore
- JkDefragGUI not packed with UPX anymore to reduce the amount of false positives by virusscanning software
- Logfiles are saved with date and time in name and can be read from within the GUI

- Logfiles can be deleted from within the GUI

- Updated Uninstaller, a registry value was left behind

JkDefragGUI 1.02 - May 8th 2008

- Added automatic detection of indonesian language at first start of JkDefragGUI
- Added disk washing, replace erased information with garbage
- Added color help to tray menu

- Fixed bug CCleaner only executed when internal cleaner is selected before CCleaner
- Fixed bug LogFileAfterDefrag setting not set in the GUI after restart
- Fixed colors green switched in JkDefrag color help
- Fixed bug Serbian language not selected in language menu

- Fixed keylogger detection by some firewall applications

- Improved BartPE Support
- Improved and reduced code

- Made GUI Smaller when in BartPE Mode

- Removed external help files from GUI to reduce size of GUI executable
- Replaced external program wait.exe with selfmade one
- Some typo corrections in multiple language files

JkDefragGUI 1.01 - January 31st 2008

- Added automatic update of the scheduled job with newest jkdefrag when downloaded
- Added automatic update of the installed version with newest jkdefrag when downloaded
- Added Croatian translation

- Added Indonesian translation
- Added option to add a delay when doing a schedule at logon
- Added option to show logfile after defragmentation (GUI only)
- Added empty prefetch folder to internal cleaner

- Added pagedefrag to the U3 version of JkDefragGUI

- Added JkDefrag history to menu
- Fixed helpfile not displayed on network drive
- Fixed bug JkDefrag version not updated when updated through automatic update at startup
- Fixed bug "Show System" selected on startup when disabled
- Fixed bug spacehogs disabled when selected and enabled when not selected

- Fixed bug scheduled job logfile not saved when using folder with spaces
- Fixed bug calendar not displayed correctly on Vista OS
- Removed screensaver copied to system32 during update when not installed

- Removed some external links in help menu from BartPE Mode

JkDefragGUI 1.00 - December 1st 2007

- Added DisableDefaults spacehogs to hidden mode
- Added Valencian translation
- Added Hebrew translation
- Added play sound when finished option
- Added save settings on exit option
- Added windows cleaning (Temp/Cookies/History/Recent/RecycleBin)
- Added registry optimizer from Lars Hederer
- Added commandline /hs runs JkDefrag hidden and shutdown after defrag
- Added commandline /reset will reset JkDefragGUI to it's defaults and restore the language files
- Added support for CCleaner /Auto

- Added english helpfile
- Added spanish helpfile
- Added dutch helpfile

- Added valencian helpfile

- Added JkDefrag version info to statusbar of GUI
- Changed downloading PageDefrag, downloaded when JkDefragGUI is started for the firsttime
- Changed combobox screensaver, made readonly
- Created a new icon for JkDefragGUI
- Fixed bug automatic download and update of JkDefrag not working 100%
- Fixed bug no logfile created with taskschedular when path with space is used
- Fixed bug debuglevel not displayed correctly in GUI
- Fixed bug monthly schedule not saved correctly
- Fixed bug when password is cleared in password field from scheduler tab scheduled job not working
- Fixed bug with "All disk" selection not released when run second time without restart
- Fixed bug email link not working on X64
- Fixed bug downloading JkDefrag.exe update
- Fixed bug wrong icon in controlpanel software
- Improved Pagedefrag options
- Improved downloading JkDefrag.exe when starting the GUI for the first time
- Improved program which checks for the existance of an U3 Device
- Improved installer function to auto install pagedefrag and jkdefrag
- Improved X64 support
- Removed "Shutdown after defrag" option from BartPe mode
- Removed automaticly check for update function from BartPE mode

JkDefragGUI 0.94 - 16 September 2007

- Fixed bug not working on Windows Vista when User Account Control (UAC) is active

JkDefragGUI 0.93 - 14 September 2007

- Corrected small typo in spacehogs explanation in all language files
- Fixed bug logfile path not restored to temp folder when settings are reset to default
- Fixed bug language files are always overwritten
- Dutch language corrections made by Alfred Spijker

JkDefragGUI 0.92 - 10 September 2007

- Added Czech translation
- Added Slovak translation
- Added Serbian translation
- Added language version check to overwrite old languages if found
- Added drivespace check when using the installer
- Added deleting pagedfrg.zip from the temp folder after download
- Added installer to the U3 version of JkDefragGUI
- Added scheduler to the U3 version of JkDefragGUI
- Added versioncheck for PageDefrag with Vista, version 2.32 and below has no Vista support
- Added update check for JkDefrag
- Added automatically updating JkDefrag en JkDefragscreensaver when update is downloaded
- Added all the missing items to the scheduler (Include/Exclude/Spacehogs)
- Added selecting language for the first time based on OS language
- Added missing color icon in BartPE mode
- Added missing transparency to changelog GUI
- Changed credit menu now smaller and scrolling
- Changed from RAR archive to ZIP archive
- Changed JK icon to new JkDefrag Icon
- Changed log file location in command line
- Improved X64 Support
- Improved GUI Speed
- Increased the calendar size for Windows 2000
- Increased the calendar size for Bulgarian regional settings
- Fixed bug error message when no internet connection detected during download PageDefrag
- Fixed bug importing shutdown settings from old ini file
- Fixed bug uninstaller not in selected language due to moved languages to folder languages
- Fixed bug tray item transparency state not set correct when closed through tray option
- Fixed bug JkDefragGUI not showing sometime when internet explorer is active
- Made uninstaller Unicode compatible
- No restart needed anymore when adding a tab
- Reduced memory usage
- Reduced CPU usage
- Removed JkDefrag from the JkDefragGUI.exe files downloaded automaticly
- Removed Sysinternals image from JkDefragGUI.exe due to copyright
- Removed background image from BartPE version
- Small cosmetic changes to scheduler checkboxes
- Supports only JkDefrag 3.17 and higher

JkDefragGUI 0.91 - 17 July 2007

- Corrected some typos in several languages
- Fixed bug error message when switching language on a Windows 2000 system
- Fixed bug running PageDefrag from folder with spaces
- Fixed bug saving "Select all fixed disks", disk selection not greyed out after restart
- Removed support for JkDefrag 3.15 and below
- Removed action 4, no longer supported by JkDefrag

JkDefragGUI 0.9 - 14 July 2007

- Made JKDefragGUI 100% Unicode compatible
- Added traditional chinese translation
- Added simplified chinese translation
- Added option to read the changelog in the GUI (English)
- Added shutdown after defrag option (Only GUI mode, not scheduler)
- Added disable default spacehogs option
- Added support for Sysinternals PageDefrag, downloaded automaticly when used
- Added selecting "Select all fixed disks" will disable single disk selection
- Added missing Spanish text "Include"
- Added exit JkDefragGUI through trayitem while defragging is active (Not with Shutdown Option)
- Added country flag icons to language menu and to the executable
- Added JkDefrag Colors to help section
- Added exclude, include and spacehogs (Move to end of data) to hidden mode
- Added download indicator to tray when downloading new version
- Added check for Windows Classic Theme to remove background image
- Fixed bug check for updates not saved correct in configuration file
- Fixed bug JkDefrag GUI freezes when update found at startup
- Fixed bug transparency not working 100% when running from U3
- Moved external programs to folder programs
- Moved languages files to folder languages
- Moved images used by the GUI to folder images
- No need for restart anymore when changing language
- Small cosmetic changes

JkDefragGUI 0.81 - 06 july 2007

- Updated JkDefragGUI to version 3.16
- Fixed bug Include/Copy to Clipboard not correct
- Fixed bug Action 11 = Analyze and sort files by creation time (oldest first) missing

JkDefragGUI 0.8 - 17 June 2007

- Updated JkDefrag to version 3.15
- Added Catalan translation
- Added Japanese translation
- Added Brazilian Portuguese translation
- Added Slovenian translation
- Added Russian translation
- Added Greek/Hellenic translation
- Added close JkDefrag when done defragging (-q option)
- Added move files to end (-u option)
- Changed program to use only external language files
- Corrected a color mismatch in the menu
- Fixed bug saving the selected installer not saved correctly to config file
- Fixed bug unable to save action 7, move to end as default
- Fixed bug exclude option not correctly copied to clipboard
- Fixed bug screensaver not replaced by newer version if older version exists
- Fixed bug task scheduler not working in Windows 2000
- Fixed bug selected language not made default when installing the GUI
- Fixed bug unable to start JkDefrag when running from U3
- Restarting the GUI made a bit faster when selecting another language
- Removed background image for Windows 2000 OS
- Removed the uninstall function of the Windows installer from the GUI
- Improved transparency to avoid colors in the GUI
- Some other minor Windows 2000 improvements

JkDefragGUI 0.7 - 28 April 2007

- Updated JkDefrag to version 3.8
- Added support for 64Bits JkDefrag
- Added Polish translation
- Added Bulgarian translation
- Added external language file support
- Added contextmenu
- Added an error message when pressing F6 and no logfile exists
- Added ability to change the path off the logfile
- Added option to disable logfile
- Added option to save logfile in GUI path
- Added option to delete logfile on exit
- Added windows installer/uninstaller
- Added the option to choose an alternative screensaver for JkDefragscreensaver installer
- Installing a newer version will create a backup of the old ini file
- Changed transparency slider to automatically set transparency (setting not saved automaticly)
- Fixed a bug in the Defrag Exclude function
- Removed fade-out on exit
- Removed user language from JkDefragGUI.INI
- Fixed bug user defined language not displayed correct
- Some code cleanup
- Some GUI improvements
- Some Vista improvements

JkDefragGUI 0.6 - 22 march 2007

- Made pull down menu read-only
- Some major changes in the GUI
- Removed balloontip from Show Scheduler
- Improved German translation
- Added more balloontips
- Added manual setting include files and folders
- Added Include and Exclude to save settings
- Added option to save logfile to alternate location
- Made logfile GUI resizable
- Added screensaver installer
- Added Hungarian translation
- Added Swedish translation
- Added options to copy command line to clipboard
- Added options to check for updates on every start of the GUI
- Fixed bug Selecting another language when run from folder with spaces Error
- Fixed bug pull down menu not compatible with Windows 2000

JkDefragGUI 0.5 - 6 March 2007

- Added Italian translation
- Added Romanian translation
- Added two more actions
- Added one more debug level
- Added free space option
- Added hidden mode from command line (Not 100% Perfect due to JkDefrag Close option)
- Added JkDefrag version 3.7 (Version 3.6 and lower will not work with GUI 0.5)
- Added Start date option to scheduler
- Added hide scheduled task and JkDefrag
- Added settings are applied to scheduler
- Added manual setting exclude files and folders
- Added hotkeys
- Added icons to GUI menu
- Added transparency to help and credit GUI
- Removed edit function from logfile
- Fixed bug task scheduler not working when JkDefrag is placed in a folder with spaces"
- Fixed bug reading a large logfile, logfile GUI not showing anything
- Fixed bug scheduler not working when no password is specified

JkDefragGUI 0.41 - 26 February 2007

- Fixed a bug JkDefrag not showing sometime
- Fixed a bug Scheduler not working when using an username with spaces

JkDefragGUI 0.4 - 24 Februari 2007

- Added USB, Floppy and Ramdisk support, drives are selectable
- Added task scheduler (Will be disabled in U3 or BartPE mode)
- Added manual save settings (even Scheduler Time/Interval/Days)
- Added restore settings to default
- Added transparency to JkDefrag and JkDefragGUI
- Added fade-out on exit
- Added Portuguese translation
- Fixed bug in User defined language JKDS050 not set
- Fixed bug wrong version saved in inifile when ini file is created
- Fixed bug wrong action selected when selecting Analyze, defragment and fast optimization

JkDefragGUI 0.3 - 11 Februari 2007

- Embedded logfile into the program
- Added printing the logfile from within program
- Added BartPE/XPE compatibility to same Executable
- Added the possibility to run JkDefragGUI from a read-only environment
- Added selecting all hard disk to defrag
- Added automatic importing old ini file and writing a new one

JkDefragGUI 0.2 - 30 January 2007

- Added four languages (Deutch/Español/Francais/Nederlands)
- Added possiblitly to add your own language (See created ini file in the same folder)
- Added update function
- Added file version and information to Executable
- Changed icon
- Created a separate Executable for BartPE/XPE
- Made JkDefragGUI 0.2 U3 Compliant

JkDefragGUI 0.1 - 16 January 2007

- Initial Release


Creditos

Créditos

Ante todo me gustaría darle las gracias a Jeroen Kessels que es el autor de JkDefrag.

Gracias a toda la gente que me reporta fallos y/o dio sugerencias para mejorar JkDefragGUI.

Pero en especial gracias a todo el mundo que me ayudó a traducir la GUI a su propio idioma.

Idioma soportado | Traductor (Gracias por ayudarme) | Versión y superiores
Brazilian Portuguese Brazilian Portuguese | Bruno Eduardo | 0.8
Bulgarian Bulgarian | Rusi Dimitrov | 0.7
Catalan Catalan | Aniol Maria | 0.8
Chinese Chinese Simplified | Tony Yu | 0.9
Chinese Chinese Traditional | Tony Yu | 0.9
Czech Croatian | Igor Hranilovic | 1.01
Czech Czech | Kamil Kroc | 0.92
Dutch Dutch | Alfred Spijker | 0.93
Dutch Dutch | Emiel Wieldraaijer | 0.2-0.92
English English | Emiel Wieldraaijer | 0.1
France France | Bernard Dechen | 0.2
German German | Guido Drehsen | 0.2
Greek Greek/Hellenic | Thanassis Katsageorgis & Xhmikos | 0.8
Hebrew Hebrew | Arik Amitzur | 1.0
Hungarian Hungarian | Tibor Sarkany | 0.6
Indonesian Indonesian | Mario Ray Mahardhika | 1.01
Italian Italian | Giandomenico Gozio | 0.5
Japanese Japanese | Daisuke Barlog | 0.8
Polish Polish | Artur Napierala | 0.7
Portuguese Portuguese | Rui Morais | 0.4
Romanian Romanian | Laurentiu Anisie | 0.5
Russian Russian | Alexander Sidorkin | 0.8
Serbian Serbian | Bojan Miladinovic | 0.92
Slovak Slovak | Peter Zilak | 0.92
Slovenian Slovenian | Zoran Kovacevic | 0.8
Spanish Spanish | Manuel Montero | 0.2
Swedish Swedish | Andreas Peterzen & Irfan | 0.6
Turkish Turkish | Offchu | 1.03
Ukrainian Ukrainian | Alexey Lugin | 1.03
Valencian Valencian | Vincente Adam | 1.0